Ubuntu 更新过程中常见问题的处理

华宰 发布于 2010/09/25 08:14
阅读 2K+
收藏 2

输入密码,没有反应

为了避免其他人看到密码的长度,在终端里不会像Windows显示*号,直接输入,回车即可,这里可以使用退格键删除已经输入的密码,同样不会显示。

升级软件出现 Could not get lock 错误

E: Could not get lock /var/cache/apt/archives/lock - open (11 Resource temporarily unavailable)E: Unable to lock the download directory 你一定把apt-get/新立得/软件更新/添加删除 等与软件安装相关的程序打开了或者是它们没运行完时就关闭了,请把他们关掉或等待他们结束吧, 或者是执行sudo rm /var/cache/apt/archives/lock命令。apt在同一时刻只能有一个在执行。

更新出现这个提示 'dpkg --configure -a'

E: dpkg was interrupted, you must manually run 'dpkg --configure -a'---- to correct the problem.E: _cache->open() failed, please report. 此问题,是由于你升级了一半,关闭了新立得,或者重启了系统,造成升级不完全,打开终端,输入 sudo dpkg --configure -a 并回车运行,来修正此问题。

unable to resolve host

进入系统->系统管理->网络,解锁后,将127.0.0.1的主机名改为localhost

或者

重启进入 recovery mode,修改 /etc/hosts 对应 127.0.0.1 的行

无法...做一个符号链接备份

E: /var/cache/apt/archives/linux-image-2.6.27-7-generic_2.6.27-7.16_i386.deb: 无法在安装新的版本前,为“./boot/vmlinuz-2.6.27-7-generic”做一个符号链接备份出现这个问题,是因为你用的wubi,且将系统安装在了fat32分区。

解决方案: sudo rm -fv /boot/initrd.img-2.6.27*.bak

sudo rm -fv /boot/vmlinuz-2.6.27-7-generic

sudo rm -fv /boot/initrd.img-2.6.27-7-generic

sudo rm -fv /boot/config-2.6.27-7-generic

sudo rm -fv /boot/abi-2.6.27-7-generic

sudo rm -fv /boot/System.map-2.6.27-7-generic

sudo rm -fv /boot/vmcoreinfo-2.6.27-7-generic

然后运行更新命令进行更新,中间会有个选择,按照默认点击下一步就可以了,等待更新完成,重启一下就可以实现正常关机了!

来源:http://forum.ubuntu.org.cn/viewtopic.php?f=48&t=174795

请采用其他安装方式,或者用wubi安装在ntfs分区。

如果只想临时解决问题,锁定出问题的包,不让它升级就可以了。

可以尝试下面的方法: 1) 在磁盘上寻找一个不是FAT的分区,或者用工具(比如UNetbootin-partitionmanager) 创建一个小分区(如256MB),将其挂载到系统中,假设分区名为/dev/sda10,挂载目录名为/mnt/bootpart,并把此信息添加到/etc/fstab文件中,比如:/dev/sda10 /mnt/bootpart ext3 defaults 0 0) 2) 在上述分区新建目录结构/ubuntu/disks/boot,把原来的/boot下面的所有内容复制过来; 3) 卸载原来的/boot(sudo umount /boot),然后将/boot挂载到新位置(sudo mount -o bind /mnt/bootpart/ubuntu/disks/boot /boot); 4) 安装deb,重启计算机,应该就可以了。

软件包有不能满足的依赖关系

正在读取软件包列表... 完成正在分析软件包的依赖关系树Reading state information... 完成有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件包尚未被创建或是它们还在新到(incoming)目录中。下列的信息可能会对解决问题有所帮助: 下列的软件包有不能满足的依赖关系: 或者:

正在读取软件包列表... 完成正在分析软件包的依赖关系树读取状态信息... 完成您也许需要运行“apt-get -f install”来纠正上面的错误。下列的软件包有不能满足的依赖关系:libhtml-parser-perl: 依赖: perlapi-5.10.0 但却无法安装它libperl5.10: 依赖: perl-base (= 5.10.0-10) 但是 5.8.8-12 已经安装了perl: 依赖: perl-base (= 5.10.0-10) 但是 5.8.8-12 已经安装了E: 不能满足依赖关系。不妨试一下 -f 选项。 出现类似上面的问题,99%以上的可能 是你设置源时把源设错了,请访问 源列表 设置好对应版本的源后再试。

注意:源的版本一定要和系统版本一致

误装 flashplugin-nonfree

如果用户不小心误装了flashplugin-nonfree ,并看到类似下面的消息:

正在设置 flashplugin-nonfree (9.0.48.0.0ubuntu1~7.04.1) ...Downloading...--20:47:05--http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_9_linux.tar.gz=> `./install_flash_player_9_linux.tar.gz'Resolving fpdownload.macromedia.com... 122.252.42.70Connecting to fpdownload.macromedia.com|122.252.42.70|:80...那么请Ctrl+c结束,然后执行

sudo apt-get remove --purge flashplugin-nonfree卸载后再按照速配指南中的方法进行安装

误装 msttcorefonts

教育网用户不能连接国外网,如果不小心误装了 msttcorefonts ,并看到类似下面的消息:

--12:06:02-- http://belnet.dl.sourceforge.net/sourceforge/corefonts/andale32.exe=> ----`./andale32.exe'正在解析主机 belnet.dl.sourceforge.net... 193.190.198.97Connecting to belnet.dl.sourceforge.net|193.190.198.97|:80...修改 /var/lib/dpkg/info/msttcorefonts.prerm 把set -e 改为 set -x 然后卸载该软件包

加载中
返回顶部
顶部