springBoot 打包时出现错误,请教高手如何处理

Liu jie 发布于 11/24 21:27
阅读 586
收藏 0

近期,我在打包一个SpringBoot的后端代码准备上线,遇到了一个错误,折磨了好几天了,始终无法解决,不知哪位高手能给出建议或思路。由于是内网项目,无法直接张贴代码和pom文件,我把照片贴出来。

我用mvn package打包时出现的错误如下:

父项目的pom文件中build部分代码如下:

子项目的web模块的Pom文件的代码build部分如下:

加载中
0
李胜飞
李胜飞

网上有人说是没找到spring-boot-maven-plugin包,他是指定了版本号解决的。

你试试呢。

0
SpringBoot中文社区
SpringBoot中文社区

我猜测是因为你自己定义了resource之类的插件,覆写了springboot默认的配置。导致了依赖没有按照springboot的方式处理打包到jar中。

0
前端啥也不会
前端啥也不会

估计是版本问题,有可能是springboot的版本和spring-boot-maven-plugin版本不兼容造成的,试着换一下这两个版本号

0
泥泽深陷

你的内网仓储里面没有对应的jar包,或者对应jar包里面没有上面那个类

0
loyal
loyal

把maven本地仓库的包全删掉,让maven重新下载.估计有jar下载失败了.

 

0
L
Liu jie

引用来自“李胜飞”的评论

网上有人说是没找到spring-boot-maven-plugin包,他是指定了版本号解决的。

你试试呢。

我这找到了spring-boot-maven-plugin包,而且我指定了版本号,我的spring Boot的版本是2.1.4,我的spring-boot-maven-plugin版本号也是2.1.4.应该能排除这方面的原因。

0
L
Liu jie

引用来自“KevinBlandy”的评论

我猜测是因为你自己定义了resource之类的插件,覆写了springboot默认的配置。导致了依赖没有按照springboot的方式处理打包到jar中。

我把maven-resources-plugin注释掉也不行啊,还是报一摸一样的错误。

0
L
Liu jie

引用来自“前端啥也不会”的评论

估计是版本问题,有可能是springboot的版本和spring-boot-maven-plugin版本不兼容造成的,试着换一下这两个版本号

这两个版本我用的都是2.1.4.REALEASE,我本地的maven版本号是3.5.3

0
L
Liu jie

引用来自“loyal”的评论

把maven本地仓库的包全删掉,让maven重新下载.估计有jar下载失败了.

 

我都删掉了,重新下载后,还是同样的错误。

0
L
Liu jie

引用来自“泥泽深陷”的评论

你的内网仓储里面没有对应的jar包,或者对应jar包里面没有上面那个类

我都删掉了,重新下载后,还是同样的错误。

返回顶部
顶部