nginx: invalid option: "‐c"

CodePrayer 发布于 03/07 11:59
阅读 447
收藏 0

在linux系统装nginx,根据配置文件启动的时候出现这个问题。在网上找了好久没找到解决办法,有大神能够解答一下吗?

加载中
0
阿润
看报错信息,某个设置重复了,日志会有详细的具体错误信息的。实在不行就重置配置文件
0
chentao106
chentao106

你的nginx不是通过yum安装的吗?这样会有很多问题,尤其是安全问题。

如果是yum安装的,所有软件直接有一套规范来存放配置文件、数据、日志、启动脚本,直接用nginx命令或systemctl就可以启动了

chentao106
chentao106
回复 @CodePrayer : 那就可能是你编译出的nginx有问题,或者服务文件不是在/usr/local/nginx/sbin/nginx下,你找找还有没别的文件。
CodePrayer
CodePrayer
不是。。。因为要安装在fastdfs的storage里,用网站进行访问
0
当朝宰相
当朝宰相

/usr/local/nginx/sbin/nginx -h 的输出贴出来

CodePrayer
CodePrayer
贴出来了,里面包含-c这个指令。。。在回答里,直接回复没图。
0
fly丶叶落
fly丶叶落
提示-c是无效的
0
zigzagroad
zigzagroad
-t 是测试配置文件是否配置正确。
CodePrayer
CodePrayer
-t这个指令也不行。。。
0
CodePrayer
CodePrayer

/usr/local/nginx/sbin/nginx -h 的输出,里面有-c这个指令 

0
桥头堡2015
桥头堡2015

能不能跑个docker容器?

CodePrayer
CodePrayer
这不是用来跑docker容器的,是用来访问fastdfs的服务的
0
H
Hejs

请问您是怎样安装nginx的?另外提供一下系统版本,gcc版本的信息。

CodePrayer
CodePrayer
截了张图在回答里,是gcc 的具体版本信息
CodePrayer
CodePrayer
先安装的FastDFS-nginx-module_v1.16.tar.gz,再安装的nginx-1.8.0.tar.gz。安装之前没有安装nginx的依赖lib,安装之后再装的依赖lib。 gcc 版本 4.4.7 20120313 (Red Hat 4.4.7-23) (GCC)
0
CodePrayer
CodePrayer

gcc的版本信息

返回顶部
顶部