QT5.1开发android “ant”打包错误

socket 发布于 2013/07/05 15:32
阅读 2K+
收藏 1

前天QT5.1正式版发布,支持android,我就下载安装想试一试。结果一切配置妥当,但在qtcreator中运行时,显示错误如下:

请问这是什么原因??我试过apache-ant-1.8.4和apache-ant-1.8.2都是同样的结果,求指导~

----------------------------------------分割线1--------------------------------------------

我在终端下输入ant -version输出如下:

kl@kl-Latitude:~$ ant -version
错误: 找不到或无法加载主类 org.apache.tools.ant.launch.Launcher

是不是和这个也有关系??

----------------------------------------分割线2--------------------------------------------

这次装好了,如下:

kl@kl-Latitude:~$ ant -version
Apache Ant(TM) version 1.9.1 compiled on July 5 2013
但还是报错:

这次确定ant安装成功,但确实qt下还是有问题,请问该怎么解决?

----------------------------------------分割线3--------------------------------------------

这次尝试还是在Qt creator 中出现上面的问题,但是我在终端下:

ant clean debug install
居然是可以正常在模拟器中运行的!!!但为什么在Qt creator中就是不能运行呢?

加载中
0
无名码农
无名码农
我的是正常的。你看下有没有其它LOG显示出来?
socket
socket
回复 @无名码农 : 在终端下ant clean debug install可以运行!!但qt creator 中还是不行。。。
socket
socket
回复 @无名码农 : 奥,是在这里头。。。还是不能运行,愁死我了。。。实在不行我只能再重装一遍了。。。谢谢你~
无名码农
无名码农
回复 @socket : 怎么会没有呢,在5.1.0/gcc/examples下面吧
socket
socket
回复 @无名码农 : 我下载的就是“Qt 5.1.0 for Android (Linux 32-bit, 463 MB)”,这个,里面没有demo啊?是不是我下错了?
无名码农
无名码农
回复 @socket : 那就不清楚了,我是先装openjdk、ant,然后下载android sdk、android ndk,然后再安装Qt-5.1,再配置下QtCreator,再打开个example,构建/部署/运行,好像都没出问题的。
下一页
0
socket
socket
ant 在命令行中可以运行,Qt creator中不能运行,这是为何。。。苦恼啊。。。
0
什中

在配置好环境变量classpath,java_home,path后,关键是看jdk路径和jdk包中lib里的tools.jar,在工具选项android配置的ant路径:填上ant包中的ant.bat文件的路径。重新启动Qt就可以了。

0
V
Volateile_xian
我也遇到过这个问题,解决方法是在path变量中添加jdk、ant等一系列的路径,然后关闭qtcreator重新打开即可
返回顶部
顶部