ffmpeg linux下截屏命令出错。。。

socket 发布于 2013/05/11 16:05
阅读 1K+
收藏 0

在ubuntu下安装完ffmpeg后,用x11grab截屏(configure时已经enable),命令如下:

ffmpeg -f x11grab -r 25 -s 800x600 -i :0.0 out.mp4
显示错误如下:

ffmpeg version 1.2.1 Copyright (c) 2000-2013 the FFmpeg developers
  built on May 11 2013 15:37:29 with gcc 4.6 (Ubuntu/Linaro 4.6.3-1ubuntu5)
  configuration: --enable-swscale --enable-postproc --enable-gpl --enable-libx264 --enable-x11grab --enable-shared --enable-libv4l2
  WARNING: library configuration mismatch
  swscale     configuration: --extra-version='4:0.8.6-0ubuntu0.12.04.1' --arch=i386 --prefix=/usr --libdir=/usr/lib/i386-linux-gnu --enable-vdpau --enable-bzlib --enable-libgsm --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-pthreads --enable-zlib --enable-libvpx --enable-runtime-cpudetect --enable-libfreetype --enable-vaapi --enable-gpl --enable-postproc --enable-swscale --enable-x11grab --enable-libdc1394 --shlibdir=/usr/lib/i386-linux-gnu/i686/cmov --cpu=i686 --enable-shared --disable-static
  postproc    configuration: --extra-version='4:0.8.6-0ubuntu0.12.04.1' --arch=i386 --prefix=/usr --libdir=/usr/lib/i386-linux-gnu --enable-vdpau --enable-bzlib --enable-libgsm --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-pthreads --enable-zlib --enable-libvpx --enable-runtime-cpudetect --enable-libfreetype --enable-vaapi --enable-gpl --enable-postproc --enable-swscale --enable-x11grab --enable-libdc1394 --shlibdir=/usr/lib/i386-linux-gnu/i686/cmov --cpu=i686 --enable-shared --disable-static
  libavutil      52. 18.100 / 52. 18.100
  libavcodec     54. 92.100 / 54. 92.100
  libavformat    54. 63.104 / 54. 63.104
  libavdevice    54.  3.103 / 54.  3.103
  libavfilter     3. 42.103 /  3. 42.103
  libswscale      2.  2.100 /  2.  1.  0
  libswresample   0. 17.102 /  0. 17.102
  libpostproc    52.  2.100 / 52.  0.  0
[x11grab @ 0x8466300] device: :0.0 -> display: :0.0 x: 0 y: 0 width: 800 height: 600
[x11grab @ 0x8466300] shared memory extension found
[x11grab @ 0x8466300] Estimating duration from bitrate, this may be inaccurate
Input #0, x11grab, from ':0.0':
  Duration: N/A, start: 1368258484.389783, bitrate: 383999 kb/s
    Stream #0:0: Video: rawvideo (BGR[0] / 0x524742), bgr0, 800x600, 383999 kb/s, 25 tbr, 1000k tbn, 25 tbc
Impossible to convert between the formats supported by the filter 'Parsed_null_0' and the filter 'auto-inserted scaler 0'
Error opening filters!

主要在最下两行,这是怎么回事儿啊?求指导:-)

加载中
返回顶部
顶部