3
回答
OpenNMS 安装错误

- Failed to load the optional jrrd library.
  - This error is not fatal, since jrrd is only required for optional features.
  - For more information, see http://www.opennms.org/index.php/jrrd
- using SQL directory... C:\PROGRA~1\OpenNMS\etc
- using create.sql... C:\PROGRA~1\OpenNMS\etc\create.sql
* using 'postgres' as the PostgreSQL user for OpenNMS
* using 'xfei6868' as the PostgreSQL password for OpenNMS
* using 'opennms' as the PostgreSQL database name for OpenNMS
Exception in thread "main" org.opennms.core.schema.MigrationException: an error occurred getting the version from the database
 at org.opennms.core.schema.Migrator.createLangPlPgsql(Migrator.java:153)
 at org.opennms.core.schema.Migrator.prepareDatabase(Migrator.java:253)
 at org.opennms.install.Installer.install(Installer.java:235)
 at org.opennms.install.Installer.main(Installer.java:859)
Caused by: org.postgresql.util.PSQLException: ERROR: could not access file "$libdir/plpgsql.so": No such file or directory
 at org.postgresql.core.v3.QueryExecutorImpl.receiveErrorResponse(QueryExecutorImpl.java:2062)
 at org.postgresql.core.v3.QueryExecutorImpl.processResults(QueryExecutorImpl.java:1795)
 at org.postgresql.core.v3.QueryExecutorImpl.execute(QueryExecutorImpl.java:257)
 at org.postgresql.jdbc2.AbstractJdbc2Statement.execute(AbstractJdbc2Statement.java:479)
 at org.postgresql.jdbc2.AbstractJdbc2Statement.executeWithFlags(AbstractJdbc2Statement.java:353)
 at org.postgresql.jdbc2.AbstractJdbc2Statement.execute(AbstractJdbc2Statement.java:345)
 at org.opennms.core.schema.Migrator.createLangPlPgsql(Migrator.java:139)
 ... 3 more

 

第九步 的时候 出现错误。

举报
flygogo
发帖于8年前 3回/1K+阅
顶部