maven项目pom文件报错,百度上的方法都解决不了

不耻下问就对了 发布于 07/16 22:24
阅读 368
收藏 0

我用过myeclipse6.5,10,2014三个版本,maven是3.6.1的,jdk7,8也都换过,每个软件环境设置、myeclipse添加maven设置都没问题,但是无论怎样pom文件都是报错。

 

文件虽然报错,但是程序可以运行(有人说可以运行就没事?),但是用pom下载的jar包(项目内有下载的jar包)好像没有产生依赖效果,在写代码的时候还是提示不能解析,需要重新导入对应的包才可以。

 

myeclipse的maven项目pom文件报错,提示如下;

org.apache.maven.archiver.MavenArchiver.getManifest(org.apache.maven.project.MavenProject, 
 org.apache.maven.archiver.MavenArchiveConfiguration)

尝试过解决不了的方法;

1、升级myeclipse的maven插件不行

2、maven强制升级不行

3、将整个C:\Users\Administrator\.m2\内的东西删除,再用myeclipse更新回来也不行

4、换低版本的maven(3.2.5)也不行

5、重装系统也不行

我是一个初学者,所以百度了几天也没解决,求赐教,拜托了,不然又要放弃了。

以下是问题补充:

@不耻下问就对了:setting.xml文件内容; <?xml version="1.0" encoding="UTF-8"?> <!-- Licensed to the Apache Software Foundation (ASF) under one or more contributor license agreements. See the NOTICE file distributed with t (07/17 10:10)
加载中
0
不耻下问就对了
不耻下问就对了
竟然还有百度解决不了的问题
0
爱De资格

eclipse的maven插件经常出怪问题的;有时候直接用命令行都比它好使

爱De资格
回复 @小白一mei : 换idea吧
不耻下问就对了
不耻下问就对了
我用的是mMyEclipse,网上全是clipse解决办法。用命令不报错嘛?
0
ch3ny
ch3ny

建议换idea

不耻下问就对了
不耻下问就对了
还在学习,不是开发
0
ilaotan
ilaotan

小哥,编辑器只是工具,myeclipse我刚毕业时用过几年,项目转maven后,时不时的会爆红,关键有的红不影响打包,报错的行也很怪异。 建议换idea,省心,初学还是别在这上面浪费时间。

0
aa00aa00
aa00aa00

看你的问题就是maven就是pom.xml文件报错是把,我这里有县城的工程,要不给你传一份,我的QQ:296462311

0
aa00aa00
aa00aa00

现成的maven工程

0
不耻下问就对了
不耻下问就对了
以上问题已解决mMyEclipse软件问题。感谢大家的帮助!
0
kali黑
kali黑

myeclipse2014不支持jdk8以上

返回顶部
顶部