命令行创建maven项目报错

superpojo 发布于 2018/08/01 11:58
阅读 390
收藏 0

环境配置:maven3.0.5 jdk:1.8
执行命令:mvn archetype:generate -DgroupId=com.ch.maven -DartifactId=simple -DarchetypeArtifactId=maven-archetype-quickstart
报错信息:Failed to execute goal org.apache.maven.plugins:maven-archetype-plugin:3.0.1:generate (default-cli) on project standalone-pom: Execution default-cli of goal org.apache.maven.plugins:maven-archetype-plugin:3.0.1:generate failed: A required class was missing while executing org.apache.maven.plugins:maven-archetype-plugin:3.0.1:generate: org/apache/maven/shared/invoker/MavenInvocationException

加载中
0
melon_jj
melon_jj

建议更换Maven更高版本 具体Maven和JDK版本兼容性看下图

melon_jj
melon_jj
回复 @superpojo : 你加我QQ了没 我语音给你说3474203856
superpojo
superpojo
回复 @melon_jj : 把本地仓库路径改成C盘默认的就可以了,还是仓库里边依赖和插件不全导致的感觉....
melon_jj
melon_jj
回复 @melon_jj 平时比较忙 所以有时候不能及时的回复你要不叫你QQ加我我语音跟你说3474203856
melon_jj
melon_jj
回复 @superpojo : 你是不是用的默认的本地仓库地址呀,如果是,你不妨更换一下maven的本地仓库地址,把本地仓库地址从C盘移到其他的盘符下,然后重新试试,如果还没解决,加群讨论吧,这样太慢了
superpojo
superpojo
回复 @melon_jj : jdk是64位的,sts也是64位的,都试过了,还是不行,是命令行创建项目,和idea没啥关系吧
下一页
0
superpojo
superpojo

maven换成3.3.9版本,但是还是报错:

[ERROR] No plugin found for prefix 'archetype' in the current project and in the
 plugin groups [org.apache.maven.plugins, org.codehaus.mojo] available from the
repositories [local (D:\maven\maven-dependcies), nexus (http://192.168.220.84:80
81/nexus/content/groups/public/)] -> [Help 1]

返回顶部
顶部