jdk版本问题,java编译出错:类文件具有错误的版本 52.0,应为 50.0请删除该文件或确保该文件位于正确的类路径子目录中

达芬奇怪乖 发布于 2019/11/21 14:24
阅读 3K+
收藏 0
JDK

1、背景:

                    公司有一个系统,jdk版本是1.6,myeclipse项目。

                    为了和项目版本一样,我将我电脑上的jdk由1.8换成了1.6(在命令行里已经显示为版本1.6)。并且在我电脑上myeclipse成功运行。

                    由于比较习惯用idea工具,想把项目转化成idea。所以在这个过程中出现了问题。

2、问题如下:

                项目导入的jar。编译出现了问题:

“类文件具有错误的版本 52.0,应为 50.0请删除该文件或确保该文件位于正确的类路径子目录中。”

Error:(3, 30) java: /F:/Users/Administrator/IdeaProjects/wanda/ac-product/src/com/wonders/ss/comm/storage/CloudStorageService.java:3: 无法访问 org.howai.commons.core.FilePathUtils
错误的类文件: jar:///F:/Users/Administrator/IdeaProjects/wanda/ac-product/WebRoot/WEB-INF/lib/commons-core-1.1.1.jar!/org/howai/commons/core/FilePathUtils.class from ZipFileObject
类文件具有错误的版本 52.0,应为 50.0
请删除该文件或确保该文件位于正确的类路径子目录中。

              并且我已经把项目jdk版本改为1.6

  

 

 

刚刚入行不久,经验欠缺,如果又遇到过这种情况的大神请帮我一下,谢谢啦

 

加载中
0
木九天
木九天
org.howai.commons.core.FilePathUtils

看一下这个文件到底那个版本不对,不是说你配置的不对,而是可能java代码用的是jdk8的,而不是6的

达芬奇怪乖
刚才看了这个文件确实使用1.8生成的。但是为什么我用myeclipse同样的用jdk1.6,项目就能正常运行。服务器也是用的1.6也是可以运行的
OSCHINA
登录后可查看更多优质内容
返回顶部
顶部