NGINX 编译报错及pcre-devel无法安装

给我蓝胖2个面子 发布于 2018/06/14 17:27
阅读 1K+
收藏 0

一、编译nginx报错:

    ./configure: error: the HTTP rewrite module requires the PCRE library.

    You can either disable the module by using --without-http_rewrite_module

    option, or install the PCRE library into the system, or build the PCRE library

    statically from the source with nginx by using --with-pcre=<path> option.

二、查看pcre  

三、yum安装pcre-devel :

     yum -y install pcre-devel

    报错Protected multilib versions: pcre-7.8-7.el6.i686 != pcre-7.8-7.kb2.ky3.x86_64

四、添加指令 --setopt=protected_multilib=false

    yum  install pcre-devel  --setopt=protected_multilib=false

    报错

    事务测试出错:

  package pcre-7.8-7.kb2.ky3.x86_64 (which is newer than pcre-7.8-7.el6.i686) is already installed

求大神解救我该怎么安装pcre-devel

 

加载中
0
不能告诉你我的名字
不能告诉你我的名字
将pcre卸载了,再来装pcre-devel呢?
给我蓝胖2个面子
不敢删,怕系统崩溃,装的还是麒麟系统,万一是定制的pcre包,重下的不匹配就完蛋了
返回顶部
顶部