关于jboot包的依赖问题

gz635 发布于 2018/09/19 17:03
阅读 194
收藏 0

【Gopher China万字分享】华为云的Go语言云原生实战经验!>>>

在最近的几个jboot版本中,发现其中依赖guava-xxx.jar,都使用了最高的版本<version>26.0-jre</version>,但该包在我自己的工程项目中其它组件也有使用到,我忽略了自己的包依赖,直接使用jboot的,但由于jboot使用的是最高版本的guava,该包中有些方法已经不存在,导致目前项目无法正常启动。看看能否将jboot中依赖的guava包版本降低到19.0?谢谢!

加载中
0
理工男海哥
理工男海哥

你可以自己在自己的pom.xml 定义项目依赖,忽略传递依赖。

返回顶部
顶部