cmake如何指定编译器

睿智的神 发布于 2017/10/22 21:00
阅读 4K+
收藏 0

我源码编译了gcc-4.8.1安装路径在/usr/local/gcc,PATH路径也添加了

PATH=/usr/local/gcc-4.8.1/bin:$PATH,但是当我室友cmake进行编译的时候,

他总是会使用以前旧的版本,我就像知道为什么这样?我有什么办法让他使用以前的gcc版本吗?

加载中
0
w
wlhe

set(CMAKE_C_COMPILER "/usr/local/gcc")

set(CMAKE_CXX_COMPILER "/usr/local/g++")

返回顶部
顶部