maqetta使用源码运行报错

sprite1 发布于 2018/06/26 11:07
阅读 112
收藏 0

参考的博客:https://www.cnblogs.com/always-online/p/3517410.html

报错信息:

!SESSION 2018-06-26 11:06:06.585 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_144
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=zh_CN
Framework arguments:  -product org.eclipse.orion.product
Command-line arguments:  -dev file:D:/maqetta_ww/.metadata/.plugins/org.eclipse.pde.core/maqetta-orion multi user/dev.properties -os win32 -ws win32 -arch x86_64 -consoleLog -console -data D:\maqetta_ww/../__maqetta_server_workspace -clean -product org.eclipse.orion.product

!ENTRY davinci.dojo_1_8 4 0 2018-06-26 11:06:08.627
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: davinci.dojo_1_8 [8]
  Unresolved requirement: Require-Bundle: maqetta.core.server; bundle-version="1.0.0"
    -> Bundle-SymbolicName: maqetta.core.server; bundle-version="1.0.0.qualifier"; singleton:="true"
       maqetta.core.server [20]
         Unresolved requirement: Require-Bundle: org.apache.commons.fileupload; bundle-version="1.2.0"

    at org.eclipse.osgi.container.Module.start(Module.java:434)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1562)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
    at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
    at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY maqetta.core.server 4 0 2018-06-26 11:06:08.630
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: maqetta.core.server [20]
  Unresolved requirement: Require-Bundle: org.apache.commons.fileupload; bundle-version="1.2.0"

    at org.eclipse.osgi.container.Module.start(Module.java:434)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1562)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
    at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
    at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY maqetta.server.configurator 4 0 2018-06-26 11:06:08.632
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: maqetta.server.configurator [21]
  Unresolved requirement: Require-Bundle: maqetta.core.server; bundle-version="1.0.0"
    -> Bundle-SymbolicName: maqetta.core.server; bundle-version="1.0.0.qualifier"; singleton:="true"
       maqetta.core.server [20]
         Unresolved requirement: Require-Bundle: org.apache.commons.fileupload; bundle-version="1.2.0"

    at org.eclipse.osgi.container.Module.start(Module.java:434)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1562)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
    at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
    at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY maqetta.server.orion 4 0 2018-06-26 11:06:08.633
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: maqetta.server.orion [22]
  Unresolved requirement: Require-Bundle: maqetta.core.server
    -> Bundle-SymbolicName: maqetta.core.server; bundle-version="1.0.0.qualifier"; singleton:="true"
       maqetta.core.server [20]
         Unresolved requirement: Require-Bundle: org.apache.commons.fileupload; bundle-version="1.2.0"

    at org.eclipse.osgi.container.Module.start(Module.java:434)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1562)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
    at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
    at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY maqetta.server.orion.authentication.ldap 4 0 2018-06-26 11:06:08.635
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: maqetta.server.orion.authentication.ldap [23]
  Unresolved requirement: Require-Bundle: org.eclipse.orion.server.useradmin; bundle-version="0.1.0"

    at org.eclipse.osgi.container.Module.start(Module.java:434)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1562)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
    at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
    at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
osgi> 
!ENTRY org.eclipse.equinox.app 0 0 2018-06-26 11:06:08.848
!MESSAGE Product org.eclipse.orion.product could not be found.
11:06:08,941 |-INFO in ch.qos.logback.classic.LoggerContext[default] - Could NOT find resource [logback.groovy]
11:06:08,941 |-INFO in ch.qos.logback.classic.LoggerContext[default] - Could NOT find resource [logback-test.xml]
11:06:08,941 |-INFO in ch.qos.logback.classic.LoggerContext[default] - Found resource [logback.xml] at [bundleresource://2.fwk600746945:1/logback.xml]
11:06:08,953 |-INFO in ch.qos.logback.core.joran.spi.ConfigurationWatchList@19f784b7 - URL [bundleresource://2.fwk600746945:1/logback.xml] is not of type file
11:06:09,011 |-INFO in ch.qos.logback.classic.joran.action.ConfigurationAction - debug attribute not set
11:06:09,013 |-INFO in ch.qos.logback.classic.joran.action.LoggerContextListenerAction - Adding LoggerContextListener of type [ch.qos.logback.classic.jul.LevelChangePropagator] to the object stack
11:06:09,039 |-INFO in ch.qos.logback.classic.jul.LevelChangePropagator@65d31f67 - Propagating DEBUG level on Logger[ROOT] onto the JUL framework
11:06:09,039 |-INFO in ch.qos.logback.classic.joran.action.LoggerContextListenerAction - Starting LoggerContextListener
11:06:09,039 |-INFO in ch.qos.logback.core.joran.action.AppenderAction - About to instantiate appender of type [ch.qos.logback.core.ConsoleAppender]
11:06:09,042 |-INFO in ch.qos.logback.core.joran.action.AppenderAction - Naming appender as [STDOUT]
11:06:09,093 |-WARN in ch.qos.logback.core.ConsoleAppender[STDOUT] - This appender no longer admits a layout as a sub-component, set an encoder instead.
11:06:09,093 |-WARN in ch.qos.logback.core.ConsoleAppender[STDOUT] - To ensure compatibility, wrapping your layout in LayoutWrappingEncoder.
11:06:09,093 |-WARN in ch.qos.logback.core.ConsoleAppender[STDOUT] - See also http://logback.qos.ch/codes.html#layoutInsteadOfEncoder for details
11:06:09,094 |-INFO in ch.qos.logback.classic.joran.action.LoggerAction - Setting level of logger [org.eclipse.orion.internal.server.search.Indexer] to INFO
11:06:09,094 |-INFO in ch.qos.logback.classic.jul.LevelChangePropagator@65d31f67 - Propagating INFO level on Logger[org.eclipse.orion.internal.server.search.Indexer] onto the JUL framework
11:06:09,095 |-INFO in ch.qos.logback.classic.joran.action.LoggerAction - Setting level of logger [org.eclipse.orion.server.login] to INFO
11:06:09,095 |-INFO in ch.qos.logback.classic.jul.LevelChangePropagator@65d31f67 - Propagating INFO level on Logger[org.eclipse.orion.server.login] onto the JUL framework
11:06:09,095 |-INFO in ch.qos.logback.classic.joran.action.LoggerAction - Setting level of logger [org.eclipse.orion.server.account] to INFO
11:06:09,095 |-INFO in ch.qos.logback.classic.jul.LevelChangePropagator@65d31f67 - Propagating INFO level on Logger[org.eclipse.orion.server.account] onto the JUL framework
11:06:09,095 |-INFO in ch.qos.logback.classic.joran.action.LoggerAction - Setting level of logger [org.eclipse.orion.server.core] to WARN
11:06:09,095 |-INFO in ch.qos.logback.classic.jul.LevelChangePropagator@65d31f67 - Propagating WARN level on Logger[org.eclipse.orion.server.core] onto the JUL framework
11:06:09,095 |-INFO in ch.qos.logback.classic.joran.action.LoggerAction - Setting level of logger [org.eclipse.orion.server.config] to INFO
11:06:09,095 |-INFO in ch.qos.logback.classic.jul.LevelChangePropagator@65d31f67 - Propagating INFO level on Logger[org.eclipse.orion.server.config] onto the JUL framework
11:06:09,095 |-INFO in ch.qos.logback.classic.joran.action.RootLoggerAction - Setting level of ROOT logger to WARN
11:06:09,095 |-INFO in ch.qos.logback.classic.jul.LevelChangePropagator@65d31f67 - Propagating WARN level on Logger[ROOT] onto the JUL framework
11:06:09,096 |-INFO in ch.qos.logback.core.joran.action.AppenderRefAction - Attaching appender named [STDOUT] to Logger[ROOT]
11:06:09,096 |-INFO in ch.qos.logback.classic.joran.action.ConfigurationAction - End of configuration.
11:06:09,098 |-INFO in ch.qos.logback.classic.joran.JoranConfigurator@5d339a30 - Registering current configuration as safe fallback point

[2018-06-26 03:06:09.136 Z] [Worker-0] INFO  org.eclipse.orion.server.config - Server configuration file loaded from: D:\meqetta源码\maqetta-Release10.0.2\releng\davinci.releng\orion\builder\rootfiles\maqetta.conf
[2018-06-26 03:06:09.172 Z] [Worker-0] INFO  org.eclipse.orion.server.config - Loaded simple metadata store (version 8).
[2018-06-26 03:06:09.174 Z] [Worker-0] INFO  org.eclipse.orion.server.config - Started Orion server authentication successfully.

!ENTRY maqetta.server.configurator 2 0 2018-06-26 11:06:09.365
!MESSAGE Could not resolve module: maqetta.server.configurator [21]
  Unresolved requirement: Require-Bundle: maqetta.core.server; bundle-version="1.0.0"
    -> Bundle-SymbolicName: maqetta.core.server; bundle-version="1.0.0.qualifier"; singleton:="true"
       maqetta.core.server [20]
         Unresolved requirement: Require-Bundle: org.apache.commons.fileupload; bundle-version="1.2.0"


!ENTRY maqetta.server.orion.authentication.ldap 2 0 2018-06-26 11:06:09.366
!MESSAGE Could not resolve module: maqetta.server.orion.authentication.ldap [23]
  Unresolved requirement: Require-Bundle: org.eclipse.orion.server.useradmin; bundle-version="0.1.0"


!ENTRY davinci.dojo_1_8 2 0 2018-06-26 11:06:09.367
!MESSAGE Could not resolve module: davinci.dojo_1_8 [8]
  Unresolved requirement: Require-Bundle: maqetta.core.server; bundle-version="1.0.0"
    -> Bundle-SymbolicName: maqetta.core.server; bundle-version="1.0.0.qualifier"; singleton:="true"
       maqetta.core.server [20]
         Unresolved requirement: Require-Bundle: org.apache.commons.fileupload; bundle-version="1.2.0"


!ENTRY maqetta.server.orion 2 0 2018-06-26 11:06:09.368
!MESSAGE Could not resolve module: maqetta.server.orion [22]
  Unresolved requirement: Require-Bundle: maqetta.core.server
    -> Bundle-SymbolicName: maqetta.core.server; bundle-version="1.0.0.qualifier"; singleton:="true"
       maqetta.core.server [20]
         Unresolved requirement: Require-Bundle: org.apache.commons.fileupload; bundle-version="1.2.0"


!ENTRY maqetta.core.server 2 0 2018-06-26 11:06:09.370
!MESSAGE Could not resolve module: maqetta.core.server [20]
  Unresolved requirement: Require-Bundle: org.apache.commons.fileupload; bundle-version="1.2.0"


!ENTRY org.eclipse.osgi 4 0 2018-06-26 11:06:09.371
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: No application id has been found.
    at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:242)
    at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:382)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:236)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:648)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:603)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1465)
    at org.eclipse.equinox.launcher.Main.main(Main.java:1438)
An error has occurred. See the log file
D:\__maqetta_server_workspace\.metadata\.log.
 

加载中
返回顶部
顶部