npm 编译十分缓慢

红参 发布于 01/02 20:38
阅读 538
收藏 0
npm

一直卡在这里,一般要1分多钟甚至更久。

以下是问题补充:

@红参:npm -v 3.9.1 node -v v10.14.0 npm list npm ERR! peer dep missing: html-webpack-plugin@^3.0.0, required by script-ext-html-webpack-plugin@2.0.1 (01/04 10:34)
@红参: UNMET PEER DEPENDENCY html-webpack-plugin@4.0.0-alpha (01/04 10:35)
@红参:npm install npm WARN optional Skipping failed optional dependency /chokidar/fsevents: npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.2.4 npm WARN script-ext-html (01/04 10:39)
@红参:版本全部正确install 用yarn安装,速度依然需要200多秒,感觉引入的依赖过多,check的时候就很慢了,这个有没有选择模块编译的方式,具体的配置文件给一个参考。,。 (01/16 11:33)
加载中
0
纯洁徐
纯洁徐

可能是依赖包文件需要下载

红参
红参
谢谢回答
0
纯洁徐
纯洁徐

不是说了么?

required by script-ext-html-webpack-plugin@2.0.1

装个yarn 配置 yarnrc 代理,然后 yarn install

返回顶部
顶部