CentOS6.5 安装cmake3.1遇到gcc问题

最爱大裤衩 发布于 2018/04/23 09:17
阅读 2K+
收藏 0
GCC

Linux基金会免费官方培训及考试申请即将截止,戳这里申请!>>>

刚开始安装cmake3.1时提示

Cannot find a C++ compiler supporting C++11 on this system.
Please specify one using environment variable CXX.
See cmake_bootstrap.log for compilers attempted.

 

然后我将gcc从4.4.7升级到4.8.5后重启后再次执行./bootstrap还是报这个错,应该怎么解决呢

加载中
0
快乐的一只小青蛙
快乐的一只小青蛙
快乐的一只小青蛙
回复 @最爱大裤衩 : 我的意思是不管是c++还是g++,都需要指向你自己的gcc环境,不能用系统自带的
最爱大裤衩
最爱大裤衩
回复 @忧郁的小王子 : 谢谢大神了,虽然还是不知道怎么解决,问题先搁置在这吧,已经卡了一两天了,我准备还是在gcc4.4.7环境下安装cmake2.8 这样应该不会报错了
快乐的一只小青蛙
快乐的一只小青蛙
回复 @最爱大裤衩 : 参考以前老的g++和c++文件
最爱大裤衩
最爱大裤衩
回复 @忧郁的小王子 : 是把c++和g++用一个新的软连接吗 ln -s /usr/local/bin/c++ /usr/local/bin/g++么
快乐的一只小青蛙
快乐的一只小青蛙
回复 @最爱大裤衩 : ln -s 源文件 目标文件
下一页
返回顶部
顶部