httpd开启mod_gnutls双向认证,出403

ThreeKidney 发布于 2017/05/12 11:10
阅读 47
收藏 0

在centos5配置了httpd的https,开启mod_gnutls设置了多个不同域名对应不同证书,但是想设置访问IP地址则要进行客户端证书验证,根据mod_gnutls的文档设置了,可是一直出现403,不知道怎么解决,请求大神抽空看看,帮忙解决一下,感激不尽。

conf.d/ssl.conf

<VirtualHost *:443>
    ServerName abc.com
    GnuTLSEnable on
    GnuTLSCertificateFile /etc/httpd/ssl/abc.com.crt
    GnuTLSKeyFile /etc/httpd/ssl/abc.com.key
    DocumentRoot "/var/www/html/abccom"
</VirtualHost>


<VirtualHost *:443>
    ServerName x.x.x.x
    GnuTLSEnable on
    GnuTLSCertificateFile /etc/httpd/ssl/own/server.crt
    GnuTLSKeyFile /etc/httpd/ssl/own/server.key
    GnuTLSClientCAFile /etc/httpd/ssl/own/ca.crt
    
    DocumentRoot "/var/www/html/ip"
    
    <Directory "/var/www/html/ip">
    Options Indexes FollowSymLinks
    AllowOverride None
    Order allow,deny
    Allow from all
    GnuTLSClientVerify require    #这一句是开启客户端证书认证,必须放在<Directory>里
    </Directory>
</VirtualHost>

可是这样设置之后还是不能访问,ip文件夹中的index.html,而是会跳到welcome中的ErrorDocument 403 /error/noindex.html

 

加载中
返回顶部
顶部