logback和slf4j版本不匹配的问题

kk545141 发布于 2017/05/10 11:05
阅读 2K+
收藏 0

运行时遇到错误:

SLF4J: The requested version 1.6 by your slf4j binding is not compatible with [1.5.5, 1.5.6, 1.5.7, 1.5.8, 1.5.9, 1.5.10, 1.5.11]
SLF4J: See http://www.slf4j.org/codes.html#version_mismatch for further details.

对这方面不是很了解,希望能知道接下来该如何操作?(按照网上搜索大多是说版本不兼容,但我lib包里面对应的都是1.7.2版本

加载中
0
北极心
北极心

建议maven配置好jar在copy进去

0
如比如比
如比如比

被害了吧:activemq-all-5.5.1.jar。参照:http://matychen.iteye.com/blog/1108827。

kk545141
kk545141
要删除的那个class名称是什么呢?谢谢啦
0
夜苍狼
夜苍狼
logback版本太旧了
夜苍狼
夜苍狼
可以加我QQ给你细说,451232398
夜苍狼
夜苍狼
你不是干开发的?
kk545141
kk545141
……,该如何解决,我现在是知道这个问题,但不知道如何解决。我对这方面不熟
0
夜苍狼
夜苍狼
给你推荐个组合,slf4j用1.7.22,logback用1.1.11,这是我用maven自动依赖出来的
返回顶部
顶部