oschina.mopaas.com服务器启动问题

gouchangxing 发布于 2014/12/17 01:04
阅读 976
收藏 0
  1. Dec 17, 2014 1:02:35 AM org.apache.catalina.core.AprLifecycleListener init

  2. INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: /usr/lib/jvm/java-6-openjdk/jre/lib/amd64/server:/usr/lib/jvm/java-6-openjdk/jre/lib/amd64:/usr/lib/jvm/java-6-openjdk/jre/../lib/amd64:/usr/java/packages/lib/amd64:/usr/lib/jni:/lib:/usr/lib

  3. Dec 17, 2014 1:02:35 AM org.apache.coyote.AbstractProtocol init

  4. INFO: Initializing ProtocolHandler ["http-bio-17564"]

  5. Dec 17, 2014 1:02:35 AM org.apache.catalina.startup.Catalina load

  6. INFO: Initialization processed in 632 ms

  7. Dec 17, 2014 1:02:35 AM org.apache.catalina.core.StandardService startInternal

  8. INFO: Starting service Catalina

  9. Dec 17, 2014 1:02:35 AM org.apache.catalina.core.StandardEngine startInternal

  10. INFO: Starting Servlet Engine: Apache Tomcat/7.0.50

  11. Dec 17, 2014 1:02:35 AM org.apache.catalina.startup.HostConfig deployDirectory

  12. INFO: Deploying web application directory /var/vcap.local/dea/apps/infolab-0-26bc3c7fe5f9394aceb8e04d2d964e90/tomcat/webapps/ROOT

  13. Dec 17, 2014 1:02:37 AM org.apache.tomcat.websocket.server.WsSci onStartup

  14. INFO: JSR 356 WebSocket (Java WebSocket 1.0) support is not available when running on Java 6. To suppress this message, run Tomcat on Java 7, remove the WebSocket JARs from $CATALINA_HOME/lib or add the WebSocketJARs to the tomcat.util.scan.DefaultJarScanner.jarsToSkip property in $CATALINA_BASE/conf/catalina.properties. Note that the deprecated Tomcat 7 WebSocket API will be available.

  15. Dec 17, 2014 1:02:37 AM org.apache.catalina.core.StandardContext startInternal

  16. SEVERE: Error filterStart

  17. Dec 17, 2014 1:02:37 AM org.apache.catalina.core.StandardContext startInternal

  18. SEVERE: Context [] startup failed due to previous errors

  19. Stopping Tomcat because the context stopped.

@红薯  老大,给我排解一下是什么问题,万分感谢!


pom.xml是这样的:

<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<groupId>HelloWorld</groupId>
<artifactId>HelloWorld</artifactId>
<version>0.0.1-SNAPSHOT</version>
<packaging>war</packaging>
<dependencies>
<dependency>
<groupId>javax.servlet</groupId>
<artifactId>servlet-api</artifactId>
<version>2.5</version>
<scope>provided</scope>
</dependency>
<dependency>
<groupId>junit</groupId>
<artifactId>junit</artifactId>
<version>3.8.1</version>
<scope>test</scope>
</dependency>
<dependency>
<groupId>com.jfinal</groupId>
<artifactId>jfinal</artifactId>
<version>1.9</version>
</dependency>
<dependency>
<groupId>org.beetl</groupId>
<artifactId>beetl-core</artifactId>
<version>2.1.1</version>
</dependency>
<dependency>
<groupId>com.jfinal</groupId>
<artifactId>jfinal-ext</artifactId>
<version>3.1.2</version>
</dependency>
<dependency>
<groupId>com.google.guava</groupId>
<artifactId>guava</artifactId>
<version>18.0</version>
</dependency>
<dependency>
<groupId>org.slf4j</groupId>
<artifactId>slf4j-log4j12</artifactId>
<version>1.7.7</version>
</dependency>
<dependency>
<groupId>log4j</groupId>
<artifactId>log4j</artifactId>
<version>1.2.16</version>
</dependency>
<dependency>
<groupId>org.slf4j</groupId>
<artifactId>slf4j-log4j12</artifactId>
<version>1.7.7</version>
</dependency>
<!-- <dependency>
<groupId>com.jfinal</groupId>
<artifactId>jetty-server</artifactId>
<version>8.1.8</version>
</dependency> -->
<dependency>
<groupId>c3p0</groupId>
<artifactId>c3p0</artifactId>
<version>0.9.1.2</version>
<scope>provided</scope>
</dependency>
<dependency>
<groupId>com.alibaba</groupId>
<artifactId>druid</artifactId>
<version>1.0.5</version>
<scope>provided</scope>
</dependency>
<!-- <dependency> <groupId>net.sf.ehcache</groupId> <artifactId>ehcache</artifactId> 
<version>2.9.0</version> </dependency> -->
<dependency>
<groupId>mysql</groupId>
<artifactId>mysql-connector-java</artifactId>
<version>5.1.34</version>
</dependency>
</dependencies>
<build>
<sourceDirectory>src</sourceDirectory>
<plugins>
<plugin>
<artifactId>maven-compiler-plugin</artifactId>
<version>3.1</version>
<configuration>
<source>1.6</source>
<target>1.6</target>
</configuration>
</plugin>
<plugin>
<artifactId>maven-war-plugin</artifactId>
<version>2.3</version>
<configuration>
<warSourceDirectory>WebContent</warSourceDirectory>
<failOnMissingWebXml>false</failOnMissingWebXml>
</configuration>
</plugin>
</plugins>
</build>
</project>

加载中
0
红薯
红薯
你用websocket了?
gouchangxing
gouchangxing
老大,帮我解决一下。
gouchangxing
gouchangxing
没有用到啊,我怎么也没有找到,我帮pom.xml贴出来了,你帮我瞅瞅。
0
iginx
iginx
第14行说的很清清楚楚了,websocket不支持JAVA6,必须是java7以上,如果没有使用websocket.jar,删除了就可以
gouchangxing
gouchangxing
可是oschina服务器的我要怎么删除呢?@iginx
iginx
iginx
@gouchangxing 在tomcat lib目录下,是tomcat自带的
gouchangxing
gouchangxing
pom.xml下面也没有啊。
0
iginx
iginx
不能升级JAVA7?那真就没有办法了
gouchangxing
gouchangxing
嗯嗯,谢谢你!
返回顶部
顶部