rabbitmq目录下sbin目录中的任何命令都无法使用,一直报错,在线等

yearDie 发布于 2018/06/28 16:09
阅读 802
收藏 0

Linux安装rabbitmq,采用解压安装的方式。erlang的版本是21

rabbitmq的版本时3.7.6,已经启动成功。。

但是,在使用rabbitmqctl命令时一直报错

而且我查看服务已经启动,在sbin目录下的任务指令都无法使用,web管理端无法进行安装

进程明明已经启动,而且应用程序已经启动起来了。为啥在使用命令的时候告诉我应用程序未启动。哪位大神知道,真心求助!!!!

加载中
0
T
Taylor_Yang

遇到和你一样的问题,最后找到原因。

根据官网的RabbitMQ Erlang版本需求文档:

http://www.rabbitmq.com/which-erlang.html

RabbitMQ 3.7.x 所要求的Erlang 版本:

最低要求19.3 ,最高支持20.3.x

所以RabbitMQ 3.7.6和Erlang 21.0 版本不匹配,把Erlang 21.0卸掉,换成Erlang 20.3就可以了

 

 

yearDie
yearDie
已解决,谢谢
返回顶部
顶部