在centos7.2上根据官网上的方式安装mesos1.1,在执行make的时候报错如下:

涌动的 发布于 2017/03/03 18:46
阅读 229
收藏 0

test "../.." = ".." || \
(/usr/bin/mkdir -p python/scheduler/src/mesos/scheduler && cp -pf ../../src/python/scheduler/src/mesos/scheduler/proxy_scheduler.hpp python/scheduler/src/mesos/scheduler/proxy_scheduler.hpp)
test "../.." = ".." || \
(/usr/bin/mkdir -p python/src/mesos && cp -pf ../../src/python/src/mesos/__init__.py python/src/mesos/__init__.py)
Building protobuf Python egg ...
cd ../3rdparty/protobuf-2.6.1/python && \
CC="gcc" \
CXX="g++" \
CFLAGS="-g1 -O0 -Wno-unused-local-typedefs" \
CXXFLAGS="-g1 -O0 -Wno-unused-local-typedefs -std=c++11" \
PYTHONPATH=/root/mesos/build/3rdparty/setuptools-20.9.0 \
/usr/bin/python setup.py build bdist_egg
Traceback (most recent call last):
File "setup.py", line 200, in 
"Protocol Buffers are Google's data interchange format.",
File "/usr/lib64/python2.7/distutils/core.py", line 112, in setup
setup_distribution = dist = klass(attrs)
File "/root/mesos/build/3rdparty/setuptools-20.9.0/setuptools/dist.py", line 269, in __init
_
self.fetch_build_eggs(attrs['setup_requires'])
File "/root/mesos/build/3rdparty/setuptools-20.9.0/setuptools/dist.py", line 313, in fetch_build_eggs
replace_conflicting=True,
File "/root/mesos/build/3rdparty/setuptools-20.9.0/pkg_resources/__init__.py", line 826, in resolve
dist = best[req.key] = env.best_match(req, ws, installer)
File "/root/mesos/build/3rdparty/setuptools-20.9.0/pkg_resources/__init__.py", line 1085, in best_match
dist = working_set.find(req)
File "/root/mesos/build/3rdparty/setuptools-20.9.0/pkg_resources/__init__.py", line 695, in find
raise VersionConflict(dist, req)
pkg_resources.VersionConflict: (pytz 2012d (/usr/lib/python2.7/site-packages), Requirement.parse('pytz>=2010'))
make[2]: *** [../3rdparty/protobuf-2.6.1/python/dist/protobuf-2.6.1-py2.7.egg] Error 1
make[2]: Leaving directory /root/mesos/build/src'
make[1]: *** [all] Error 2
make[1]: Leaving directory
/root/mesos/build/src'
make: *** [all-recursive] Error 1

加载中
0
涌动的

问题已解决,升级下pytz就可以了:

#pip install pytz --upgrade

返回顶部
顶部