linux下多个版本python安装twisted问题 急急急!

kyle_Ng 发布于 2017/09/17 16:50
阅读 269
收藏 0

linux系统:ubuntu

python版本:2.7.12 和 3.5.2

安装了virtualenv和virtualenvwrapper,然后分别创建了两个python版本的虚拟环境,

在python2版本下面安装twisted没有问题,但是在python3版本下安装的时候就报错误。

src/twisted/test/raiser.c:4:20: fatal error: Python.h: No such file or directory
    compilation terminated.
    error: command 'x86_64-linux-gnu-gcc' failed with exit status 1

我已经安装了python-dev,请问什么方法可以让我的twisted安装到python3版本下面的虚拟环境呢?

加载中
0
g
giguga

从系统的软件源中安装python3-dev

k
kyle_Ng
感谢 按照你说的方法我安装了python3-dev解决了安装问题。 但是我还有个问题,我现在有两个python3版本的python,一个是3.5一个3.6 直接apt-get install python3-env会安装到3.5,我想让3.6也起作用需要怎么做呢?
返回顶部
顶部