maven项目中出现红叉这个问题,如何解决?

Jeocy 发布于 2017/03/21 23:16
阅读 1K+
收藏 0

加载中
0
开源中国首席大弟子
开源中国首席大弟子

右击项目->Maven->update  project

开源中国首席大弟子
开源中国首席大弟子
回复 @紫梦幻 : 这个是因为maven默认配置的是1.5 需要手工改下 可以改引用的settings.xml也可直接写在pom.xml中 <profile> <id>jdk-1.8</id> <activation> <activeByDefault>true</activeByDefault> <jdk>1.8</jdk> </ac
Jeocy
Jeocy
贴上去了,我把版本改了1.7的了,update的时候又变成1.5了、
开源中国首席大弟子
开源中国首席大弟子
回复 @紫梦幻 : 看看Markers中提示错误是什么
Jeocy
Jeocy
都试了,但是还是没有解决、
0
草的高度
草的高度

把错误信息贴上来看看啊

Jeocy
Jeocy
刚刚已经贴上去、我把版本改成1.7的了,还是有问题、
0
草的高度
草的高度

百度“eclipse如何修改项目为Dynamic Web Module 3.0”

Jeocy
Jeocy
谢谢大家,已经解决了、
0
求是科技
求是科技

我遇到过这个问题,是各个插件的版本不匹配的问题,你设置的 Dynamic Web Module 是3.0,你可以在eclipse中找到设置Dynamic Web Module的地方,或者简单的修改web.xml的内容,将web.xml的头部设置成

<!DOCTYPE web-app PUBLIC
 "-//Sun Microsystems, Inc.//DTD Web Application 2.3//EN"
 "http://java.sun.com/dtd/web-app_2_3.dtd" >

 

Jeocy
Jeocy
谢谢,已经解决了,在setting.xml中加入了 <profile> <id>jdk-1.7</id> <activation> <activeByDefault>true</activeByDefault> <jdk>1.7</jdk> </activation
返回顶部
顶部