maven运行mvn install时报错。项目中启动tomcat就找不到spring的依赖包。

不吃桃的monkey 发布于 2017/06/19 10:08
阅读 321
收藏 0

在eclipse这种启动tomcat就找不到spring的依赖包。但是我看Maven Dependencies里面又有这些依赖。这些依赖后面的地址也是本地仓库的地址。后面我运行mvn install的看到报错了。在运行其他命令都是错的 ,只有mvn -version是能够查看到版本。问下大神这是什么原因啊?怎么解决。谢谢

以下是问题补充:

@不吃桃的monkey:现在新建maven项目也不行了。 (2017/06/19 11:01)
加载中
0
bigtk
bigtk

試試 mvn help:system

bigtk
bigtk
回复 @不吃桃的monkey : 没有pom mvn install会报错
不吃桃的monkey
不得行,还是要报错。
0
=
===

路径问题吧,你的mvn install命令得在你的项目路径下运行吧

=
===
回复 @不吃桃的monkey : 项目目录,,,不是说maven的安装目录
不吃桃的monkey
在maven目录下也不行
0
南北024
南北024

这错不是很明显了吗? 路径下没有找到pom文件

口发
回复 @不吃桃的monkey : eclipse内配置的maven路径没有配对
不吃桃的monkey
他是在C盘里面去找。但是我配置了本地仓库在D盘啊。
0
polly
polly
你在adminstrator目录里搞灰机呢,cd到项目目录再执行
返回顶部
顶部