python pip安装报错【error: Microsoft Visual C++ 10.0 is required. 】

walters33 发布于 2016/12/05 15:48
阅读 2K+
收藏 0
最近在windows下用pip安装superset时,报如下错误:

    running build_ext
    building 'sasl.saslwrapper' extension
    error: Microsoft Visual C++ 10.0 is required. Get it with "Microsoft Windows
 SDK 7.1": www.microsoft.com/download/details.aspx?id=8279

    ----------------------------------------
Command ""d:\program files\python34\python.exe" -u -c "import setuptools, tokeni
ze;__file__='C:\\Users\\dba2bar\\AppData\\Local\\Temp\\2\\pip-build-o4g7qomx\\sa
sl\\setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace(
'\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record
C:\Users\dba2bar\AppData\Local\Temp\2\pip-knwyb00k-record\install-record.txt --s
ingle-version-externally-managed --compile" failed with error code 1 in C:\Users
\dba2bar\AppData\Local\Temp\2\pip-build-o4g7qomx\sasl\

在根据提示成功安装SDK 7.1后,再次尝试安装,却仍然报同一错误,卸载后重新安装仍然如此,不知道哪位大大有同样的遭遇,可以提点下?谢谢!
加载中
0
Jamie-Liu
Jamie-Liu
https://www.microsoft.com/en-us/download/details.aspx?id=44266
返回顶部
顶部