部署spring boot项目到websphere8.5错误

爱吃蛋挞的kk 发布于 12/06 14:39
阅读 46
收藏 0

ConfigServletWebServerApplicationContext : Exception encountered during context initialization - cancelling refresh attempt: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'defaultValidator' defined in class path resource [org/springframework/boot/autoconfigure/validation/ValidationAutoConfiguration.class]: Invocation of init method failed; nested exception is java.lang.NoSuchMethodError: javax/validation/Configuration.getDefaultParameterNameProvider()Ljavax/validation/ParameterNameProvider; (loaded from file:/D:/Program Files (x86)/IBM/WebSphere/AppServer/plugins/javax.j2ee.validation.jar by org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader@2f26e9d9) called from class 

 

项目要支持几种服务器的部署例如websphere web logic tomcat 等其他的都没问题闲坐就websphere部署搞不定了,有没有大佬遇到过帮我看看这个怎么搞得

 

加载中
0
爱吃蛋挞的kk
爱吃蛋挞的kk

查到有人说sring5.x 和WebSphere8.5不兼容要么升级到9.x要么降级spring到4.x很恶心。。。

返回顶部
顶部