Ubuntu16.04LTS U盘启动时找不到ACPI

ljq666 发布于 2016/11/27 14:36
阅读 1K+
收藏 0
 问题描述:用U盘装Ubuntu系统时,在进入LiveCD试用或者安装界面前会闪现以下几行代码:

【   5.211875】DMAR:Failed to find handle for ACPI object \_SB.PCIO.SDMA

【   5.211985】DMAR:Failed to find handle for ACPI object \_SB.PCIO.SDHC

【   5.438385】radeon 0000:04:00.0:VCE init error(-22).

然后可进入安装界面,一直到选择城市后,点击继续不是进行安装而是会进入试用系统,然后桌面上说出现系统内部错误。

注释:

我在BIOS中关闭独显后,除了第三行错误代码提示消失后,然后的情况还是老样子

我用过UltraISO,PowerISO,USB Installer,UNetbootin工具烧制Ubuntu11.04LTS,14.04LTS,16.04LTS,CentOS7启动盘都会出现上述问题;我用硬盘安装Ubuntu也还会出现上述问题描述

我的电脑是联想G50-80,电脑OS是win7,磁盘格式MBR 

加载中
0
eechen
eechen
你说的应该是Ubuntu 16.04 LTS吧,没有16.01这种编号的版本的.

看错误是因为AMD的radeon显卡的问题.
建议在BIOS里关闭独显(就是你的radeon显卡),然后再进行安装.
以我的本子为例,具体操作就是在BIOS中把Graphic Mode由Switchable改为Integrated即可禁用独显.
你的i7处理器自带的核显已经足够用了,能关掉独显尽量关掉吧,这是我的建议.

Ubuntu上用i5-3230M核芯显卡在VirtualBox虚拟XP里玩3D赛车游戏LFS.

l
ljq666
我刚才试了下,把独显关了之后第三行错误代码没了,但是前两行错误代码还有。我这次试了下硬盘安装和U盘安装都会出现我上述问题,即出现前两行错误代码,然后选择城市后点击继续就又是出现系统内部错误,不能安装
l
ljq666
是16.04我打错了,我现在试试,谢谢你,非常感激
0
eechen
eechen
我写了篇Win7上硬盘安装Ubuntu的博文,你参考下:
https://my.oschina.net/eechen/blog/211683
ACPI是高级配置和电源管理接口,你可以尝试关闭它.
具体方法就是加入内核参数 acpi=off 如:
title Ubuntu Live CD
root (hd0,4)
kernel /ubuntu/vmlinuz.efi boot=casper iso-scan/filename=/ubuntu/ubuntu.iso acpi=off
initrd /ubuntu/initrd.lz



如果能启动的话依次尝试加入下列参数定位问题:
acpi=ht pci=noacpi acpi=noirq pnpacpi=off noapic nolapic
https://wiki.ubuntu.com/DebuggingACPI

安装好启动Ubuntu时也加入这个参数,如:
title Ubuntu GNU/Linux
root (hd0,7)
kernel /vmlinuz root=/dev/sda8 ro quiet splash acpi=off
initrd /initrd.img



我在安装时把引导程序安装到Ubuntu的根分区/dev/sda8即可,没有选择安装到整块硬盘/dev/sda,这样开机后仍可以通过Windows上的grub4dos进行引导.
l
ljq666
你说的添加内核参数是添加启动内核的参数吧,我今天试了下添加启动内核参数,还是在进入之前会闪现前两行错误代码。我是这样添加的,以U盘启动后选择编辑然后输入你说的代码,还是会出现同样的问题
返回顶部
顶部