requirejs 加载jq时随机性出现错误

Rum__ 发布于 2016/10/10 13:48
阅读 584
收藏 0

这个错误有时候会出现,刷新之后又正常,错误如下:

GET http://192.168.0.157:8020/demo/public/Hb/static/jquery.js
Uncaught Error: Script error for "jquery", needed by: ../views/login/login
http://requirejs.org/docs/errors.html#scripterror

配置里面的jQuery路径是jquery-2.1.4.min,为什么get的路径会是jquery.js,这个问题如何解决?

加载中
0
wuyiw
wuyiw
配置是不是也是异步加载? 有时候配置滞后了,  就用了默认的jquery.js?
Rum__
Rum__
已经解决了,是因为c模块依赖a和b模块,而a和b是依赖jq的,requirejs是异步导入模块的,所以导致ab同时要使用jq导致。用回调的方式导入,即先导入a然后在回调里在导入b就不会出现这个问题了
返回顶部
顶部