JSP页面全部不能访问

转眼 发布于 2016/09/22 22:41
阅读 507
收藏 0

HTTP Status 500 -


type Exception report

message

description The server encountered an internal error () that prevented it from fulfilling this request.

exception

org.apache.jasper.JasperException: Unable to compile class for JSP: 

An error occurred at line: 1 in the generated java file
The type java.io.ObjectInputStream cannot be resolved. It is indirectly referenced from required .class files

Stacktrace:
	org.apache.jasper.compiler.DefaultErrorHandler.javacError(DefaultErrorHandler.java:92)
	org.apache.jasper.compiler.ErrorDispatcher.javacError(ErrorDispatcher.java:330)
	org.apache.jasper.compiler.JDTCompiler.generateClass(JDTCompiler.java:423)
	org.apache.jasper.compiler.Compiler.compile(Compiler.java:316)
	org.apache.jasper.compiler.Compiler.compile(Compiler.java:294)
	org.apache.jasper.compiler.Compiler.compile(Compiler.java:281)
	org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:566)
	org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:317)
	org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:337)
	org.apache.jasper.servlet.JspServlet.service(JspServlet.java:266)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
	org.apache.struts2.dispatcher.ng.filter.StrutsPrepareAndExecuteFilter.doFilter(StrutsPrepareAndExecuteFilter.java:88)

note The full stack trace of the root cause is available in the Apache Tomcat/6.0.16 logs.

JDK8 ; tomcat 6 ;最新版的Spring插件 和 hibernate 插件 . 

现在 jsp不能打开

加载中
0
模糊的张狂
模糊的张狂

异常的第一行不是写的,不能把jsp编译成class么……

你看看 是不是有   没有导入的jar

转眼
转眼
改了工作空间就ok了非版本问题
0
lieefu
lieefu
tomcat版本太低了,请升级到tomcat 8
转眼
转眼
改了工作空间就ok了非版本问题
0
原版什锦八宝饭
原版什锦八宝饭

有些容器编译jsp文件时会自动导入java.io     java.util包,有些不会。这个错误是因为jsp文件没有在jsp页面显式import java.io包

你都用jdk8了,建议你直接用tomcat8版本好了,

转眼
转眼
改了工作空间就ok了非版本问题
返回顶部
顶部