IE不支持echarts3.0的shadowBlur效果

aefrost 发布于 2016/09/07 17:34
阅读 716
收藏 0

你好,林老师@Kener-,我想反馈一个echarts3.0的兼容问题。

今天开发找到我说有个页面不显示并且js报错。我当时觉得是应该是他在修改的时候出的问题,因为我用谷歌,火狐,edge都测试过的。他说他拿过来没动过。我们就用火狐试了一下,正常。然后我们意识到可能是“fuckIE”的问题,因为提示的错误是echarts.js里的错误。那个出错是不可能的。对照手册一点点的屏蔽测试,发现原来就是:

shadowBlur:200,

这个选项的问题。屏蔽了之后就能显示。按说IE9就支持阴影效果了啊,我用的11不应该出现问题啊,但确实是找个的问题。我是初学者,对js本身不熟,不清楚是不是echarts本身的兼容问题。如果真的是的话,恳请尽快完善。

加载中
返回顶部
顶部