maven插件安装问题

巴西内马尔 发布于 2016/09/01 15:52
阅读 812
收藏 0

       我在Maven官网下载了maven3.0.5。

       我的Eclipse版本是4.2.0;JDK版本是1.8.0_72

       我可以正确的安装maven。但在安装maven插件时,总是遇到问题。①离线安装:我按照网上的教程,在eclipse路径下新建link和myplugins文件夹。在link中我存放了maven.links,用来指向maven插件;在myplugins中我新建了maven文件夹,在这个文件夹中我将maven插件解压后的eclipse全复制到这个文件夹下。但重启eclipse后,我没有在window-preferences中找不到Maven。②用在线安装:安装的网址是:Maven3 - http://download.eclipse.org/technology/m2e/releases;可以看见maven的版本号等。我勾选,安装。但会失败:Cannot complete the install because one or more required items could not be found.   Software being installed: m2e - slf4j over logback logging (Optional) 1.7.0.20160603(报错信息)

      求大神指导一下!!!新手遇到麻烦了,不知道怎么解决。

加载中
0
混分小菜鸟
混分小菜鸟
混分小菜鸟
回复 @我觉得他很厉害 : 如果工作是maven框架的工程的,尽早换intellij idea 吧,比Eclipse好用很多
巴西内马尔
巴西内马尔
不懂,能说的更明白点吗?
0
长方体混凝土移动大师
长方体混凝土移动大师
没有这么麻烦吧。。。
巴西内马尔
巴西内马尔
我也不知道,插件安装不上
0
长方体混凝土移动大师
长方体混凝土移动大师
下载maven的离线包,然后在eclipse中配置maven的路径,注意在配置的设置maven中setting.xml文件中本地仓库和maven的镜像地址。
巴西内马尔
巴西内马尔
我现在是maven插件安装不上,试了离线和在线安装都不行。
0
v若水
v若水
我记得eclipse自带maven插件呀
巴西内马尔
巴西内马尔
我这个版本好像没有。只能自己装插件,再安装
0
烟雨三月
烟雨三月
http://download.eclipse.org/technology/m2e/releases 多试几个版本。有些版本不兼容,会出错。
0
草的高度
草的高度
maven插件安装的mirror一定要用官方推荐的,国内的mirror是有缺失的。别贪国内的mirror下载依赖快。
巴西内马尔
巴西内马尔
嗯,我在找找..
0
大豪_
大豪_
eclipse自带maven,你也可以自己去官网下载解压,然后在eclipse中选择:preferences-->maven-->installations,把你下载的maven路径引入到eclipse就行了
巴西内马尔
巴西内马尔
我的好像不自带。在preferences里面好像没有maven...
返回顶部
顶部