spring boot data solr 的版本最高只支持 solrj5.5.4吗?

千百百度 发布于 2018/01/10 15:46
阅读 710
收藏 1

我现在用的solr版本是solr7.1,solrj的版本也有7.1的,但是最近boss想整合springboot,然后我就去springboot的官网找,定睛一看,springboot整合solr是用spring-boot-data-solr的,但是我用maven 把jar下载下来之后发现,solrj的版本仅仅是5.5.4,着就让我很尴尬了。请问各位大神,这件事是springboot没更新吗,还是我找错了?

加载中
0
千百百度
千百百度

问题已解决,https://stackoverflow.com/questions/48181816/spring-boot-data-only-support-solrj5-5。

0
TheNowWjj
TheNowWjj

不用 spring-boot-data-solr ,自己写solr依赖,然后数据处理用你习惯用的依赖来实现? 自己再写一个solr的spring boot starter 或者自己写一个Configuration?
猜测,没整合过solr,仅限参考。

TheNowWjj
TheNowWjj
@千百百度 回复@千百百度 : 啊哦,那我也不知道了- -
千百百度
千百百度
嗯,现在我自己用的是solr jar 实现的solr的增删改。现在就是不确定spring boot是不是最高整合solr的版本就是5.5.4.
0
skhuhu
skhuhu

升级springboot 版本

返回顶部
顶部