Linux下安装多个jdk使用问题

樱木花道VS康 发布于 2017/09/04 21:00
阅读 253
收藏 0
JDK

大家好,我在centOs7下安装了两个jdk,1.7以及1.8使用的rpm安装方式,配置文件中配置的是1.7的环境变量,但是java -version显示的却是1.8请问怎么配置使用呢?是哪里的问题呢?我是先安装的1.7,后来安装的java8

加载中
0
樱木花道VS康
樱木花道VS康

解决了,连接的问题,环境变量改了后,需要添加连接修改之前的连接:

cd /usr/bin

ll java  链接的是之前的jdk版本

ll javac 

修改:

ln -s -f /usr/java/jdk1.6.0_24/jre/bin/java     

ln -s -f /usr/java/jdk1.6.0_24/bin/javac    修改为自己想要使用的jdk路径即可

0
活灬在当灬下
活灬在当灬下

你把环境变量改了不就好了

0
map150
map150

Ubuntu下,bin文件夹下有个软链接,直接java -version的时候,找的是这个软链接,centos下会不会也是类似的机制

0
Lob
Lob

看你的用户下的.bash_profile和/etc/profile这两个文件下的jdk配置。

0
q867765383
q867765383

请问下你修改后版本应该是1.7的?

q867765383
q867765383
回复 @樱木花道VS康 : 好的,了解了。谢谢!
樱木花道VS康
樱木花道VS康
对的,我是1.7跟1.8切换的,那只是个例子
返回顶部
顶部