gcc与c++安装遇到rpm依赖包错误

lsm121 发布于 2016/05/04 18:33
阅读 5K+
收藏 1
centOS6.5下  安装pcre-8.38时,报没有安装gcc环境,  我去网上下载rpm包依次安装  但是到 安装libgomp,cpp时都报依赖错误,麻烦大神帮忙看下  而且 前面试装docker的时候修改过yum的配置文件 yum下载也不好使了  谢谢各位。
[root@lsm121 pcre-8.38]# ./configure
...
checking windows.h presence... no
checking for windows.h... no
configure: error: You need a C++ compiler for C++ support.
[root@lsm121 local]# rpm -Uvh libgomp-4.4.7-4.el6.x86_64.rpm 
error: Failed dependencies:
	libgomp = 4.4.7-16.el6 is needed by (installed) gcc-4.4.7-16.el6.x86_64
[root@lsm121 local]# rpm -Uvh gcc-4.4.7-4.el6.x86_64.rpm 
error: Failed dependencies:
	cpp = 4.4.7-4.el6 is needed by gcc-4.4.7-4.el6.x86_64
	libgomp = 4.4.7-4.el6 is needed by gcc-4.4.7-4.el6.x86_64
[root@lsm121 local]# rpm -Uvh cpp-4.4.7-4.el6.x86_64.rpm 
error: Failed dependencies:
	cpp = 4.4.7-16.el6 is needed by (installed) gcc-4.4.7-16.el6.x86_64
[root@lsm121 local]# rpm -Uvh gcc-c++-4.4.7-4.el6.x86_64.rpm 
error: Failed dependencies:
	gcc = 4.4.7-4.el6 is needed by gcc-c++-4.4.7-4.el6.x86_64
[root@lsm121 local]# rpm -Uvh cpp-4.4.7-4.el6.x86_64.rpm 
error: Failed dependencies:
	cpp = 4.4.7-16.el6 is needed by (installed) gcc-4.4.7-16.el6.x86_64
[root@lsm121 local]# rpm -ivh cpp-4.4.7-4.el6.x86_64.rpm 
Preparing...                ########################################### [100%]
	package cpp-4.4.7-16.el6.x86_64 (which is newer than cpp-4.4.7-4.el6.x86_64) is already installed
	file /usr/bin/cpp from install of cpp-4.4.7-4.el6.x86_64 conflicts with file from package cpp-4.4.7-16.el6.x86_64
	file /usr/libexec/gcc/x86_64-redhat-linux/4.4.4/cc1 from install of cpp-4.4.7-4.el6.x86_64 conflicts with file from package cpp-4.4.7-16.el6.x86_64
[root@lsm121 local]# rpm -ivh libgomp-4.4.7-4.el6.x86_64.rpm 
Preparing...                ########################################### [100%]
	package libgomp-4.4.7-16.el6.x86_64 (which is newer than libgomp-4.4.7-4.el6.x86_64) is already installed
	file /usr/lib64/libgomp.so.1.0.0 from install of libgomp-4.4.7-4.el6.x86_64 conflicts with file from package libgomp-4.4.7-16.el6.x86_64
[root@lsm121 local]# rpm -Uvh gcc-4.4.7-4.el6.x86_64.rpm 
error: Failed dependencies:
	cpp = 4.4.7-4.el6 is needed by gcc-4.4.7-4.el6.x86_64
	libgomp = 4.4.7-4.el6 is needed by gcc-4.4.7-4.el6.x86_64
[root@lsm121 local]# rpm -ivh gcc-4.4.7-4.el6.x86_64.rpm 
error: Failed dependencies:
	cpp = 4.4.7-4.el6 is needed by gcc-4.4.7-4.el6.x86_64
	libgomp = 4.4.7-4.el6 is needed by gcc-4.4.7-4.el6.x86_64
[root@lsm121 local]# rpm -i gcc
error: open of gcc failed: No such file or directory
[root@lsm121 local]# yum install gcc
Setting up Install Process
Nothing to do



加载中
0
鲁小鹿
鲁小鹿

yum源修复方式:https://lug.ustc.edu.cn/wiki/mirrors/help/centos (使用国内的源下载速度会快点) 下载对应的centos版本

然后放置在/etc/yum.repos.d下,yum makecache一下,如果系统装有wget,直接wget下载也可

[xiaolu@lucia root]$ cd /etc/yum.repos.d/
[xiaolu@lucia yum.repos.d]$ sudo mv CentOS-Base.repo CentOS-Base.repo.bak
[xiaolu@lucia yum.repos.d]$ sudo wget -O CentOS-Base.repo https://lug.ustc.edu.cn/wiki/_export/code/mirrors/help/centos?codeblock=2  
[xiaolu@lucia yum.repos.d]$ yum makecache



你的./configure 报错很明显的报错了You need a C++ compilerfor C++ support
[root@lsm121 local]# rpm -Uvh gcc-4.4.7-4.el6.x86_64.rpm 
error: Failed dependencies:
    cpp = 4.4.7-4.el6 is needed by gcc-4.4.7-4.el6.x86_64
    libgomp = 4.4.7-4.el6 is needed by gcc-4.4.7-4.el6.x86_64

第一层楼里面你写的是安装gcc及gcc的依赖包(然后都报的依赖包的错误)

有两种方式:

修复yum,你可以直接yum安装

不修复yum源,你安装gcc及其他依赖包的时候,加上参数 --force --nodeps

例如:

rpm -Uvh gcc-4.4.7-4.el6.x86_64.rpm --nodeps --force




l
lsm121
谢谢 从你的回答里又学到了很多东西
0
l
lsm121

我最先是在网上看的  这样安装的

[root@lsm121 local]# rpm -Uvh kernel-headers-2.6.32-431.el6.x86_64.rpm
Preparing...                ########################################### [100%]
	package kernel-headers-2.6.32-431.el6.x86_64 is already installed
[root@lsm121 local]# rpm -Uvh glibc-headers-2.12-1.132.el6.x86_64.rpm
Preparing...                ########################################### [100%]
	package glibc-headers-2.12-1.132.el6.x86_64 is already installed
[root@lsm121 local]# rpm -Uvh glibc-devel-2.12-1.132.el6.x86_64.rpm
Preparing...                ########################################### [100%]
	package glibc-devel-2.12-1.132.el6.x86_64 is already installed
[root@lsm121 local]# rpm -Uvh libgomp-4.4.7-4.el6.x86_64.rpm
error: Failed dependencies:
	libgomp = 4.4.7-16.el6 is needed by (installed) gcc-4.4.7-16.el6.x86_64
[root@lsm121 local]# rpm -Uvh ppl-0.10.2-11.el6.x86_64.rpm
Preparing...                ########################################### [100%]
	package ppl-0.10.2-11.el6.x86_64 is already installed
[root@lsm121 local]# rpm -Uvh cloog-ppl-0.15.7-1.2.el6.x86_64.rpm
Preparing...                ########################################### [100%]
	package cloog-ppl-0.15.7-1.2.el6.x86_64 is already installed
[root@lsm121 local]# rpm -Uvh mpfr-2.4.1-6.el6.x86_64.rpm
Preparing...                ########################################### [100%]
	package mpfr-2.4.1-6.el6.x86_64 is already installed
[root@lsm121 local]# rpm -Uvh cpp-4.4.7-4.el6.x86_64.rpm
error: Failed dependencies:
	cpp = 4.4.7-16.el6 is needed by (installed) gcc-4.4.7-16.el6.x86_64
[root@lsm121 local]# rpm -Uvh gcc-4.4.7-4.el6.x86_64.rpm
error: Failed dependencies:
	cpp = 4.4.7-4.el6 is needed by gcc-4.4.7-4.el6.x86_64
	libgomp = 4.4.7-4.el6 is needed by gcc-4.4.7-4.el6.x86_64
[root@lsm121 local]# pm -Uvh libgomp-4.4.7-4.el6.x86_64.rpm
-bash: pm: command not found
[root@lsm121 local]# rpm -Uvh libgomp-4.4.7-4.el6.x86_64.rpm
error: Failed dependencies:
	libgomp = 4.4.7-16.el6 is needed by (installed) gcc-4.4.7-16.el6.x86_64
[root@lsm121 local]# rpm -Uvh libstdc++-devel-4.4.7-4.el6.x86_64.rpm
Preparing...                ########################################### [100%]
   1:libstdc++-devel        ########################################### [100%]



0
l
lsm121

引用来自“鲁小鹿”的评论

yum源修复方式:https://lug.ustc.edu.cn/wiki/mirrors/help/centos (使用国内的源下载速度会快点) 下载对应的centos版本

然后放置在/etc/yum.repos.d下,yum makecache一下,如果系统装有wget,直接wget下载也可

[xiaolu@lucia root]$ cd /etc/yum.repos.d/
[xiaolu@lucia yum.repos.d]$ sudo mv CentOS-Base.repo CentOS-Base.repo.bak
[xiaolu@lucia yum.repos.d]$ sudo wget -O CentOS-Base.repo https://lug.ustc.edu.cn/wiki/_export/code/mirrors/help/centos?codeblock=2  
[xiaolu@lucia yum.repos.d]$ yum makecache



你的./configure 报错很明显的报错了You need a C++ compilerfor C++ support
[root@lsm121 local]# rpm -Uvh gcc-4.4.7-4.el6.x86_64.rpm 
error: Failed dependencies:
    cpp = 4.4.7-4.el6 is needed by gcc-4.4.7-4.el6.x86_64
    libgomp = 4.4.7-4.el6 is needed by gcc-4.4.7-4.el6.x86_64

第一层楼里面你写的是安装gcc及gcc的依赖包(然后都报的依赖包的错误)

有两种方式:

修复yum,你可以直接yum安装

不修复yum源,你安装gcc及其他依赖包的时候,加上参数 --force --nodeps

例如:

rpm -Uvh gcc-4.4.7-4.el6.x86_64.rpm --nodeps --force




谢谢 从你的回答里又学到了很多东西
0
漓江
漓江

--node-force这种方式不推荐,虽然可以安装gcc&c++,但以后使用的时候,会发生许多莫名其貌的问题,最后花时间调查发现原来是gcc&c++安装不正确导致的。

你可以去你的centOS6.5的ISO镜像文件中,找到package下gcc&c++的rpm包,解压出来后直接安装即可。

返回顶部
顶部