Linux下 GTK+ 安装

jingweiyoung 发布于 2012/07/05 19:05
阅读 11K+
收藏 0

今天在Linux上安装 GTK+,我下载的gtk+-3.2.0.tar.bz2 。按官网的说明要提前安装"GLib, Pango, Gdk-Pixbuf, ATK"这几个包,我查了下系统都有。

结果./configure --prefix=/usr 之后报错

checking for BASE_DEPENDENCIES... no
configure: error: Package requirements (glib-2.0 >= 2.29.14    atk >= 2.1.5    pango >= 1.29.0    cairo >= 1.10.0    cairo-gobject >= 1.10.0    gdk-pixbuf-2.0 >= 2.23.5) were not met:

Requested 'glib-2.0 >= 2.29.14' but version of GLib is 2.12.3
Requested 'atk >= 2.1.5' but version of Atk is 1.12.2
Requested 'pango >= 1.29.0' but version of Pango is 1.14.9
Requested 'cairo >= 1.10.0' but version of cairo is 1.2.4
No package 'cairo-gobject' found
Requested 'gdk-pixbuf-2.0 >= 2.23.5' but version of GdkPixbuf is 2.10.4

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables BASE_DEPENDENCIES_CFLAGS
and BASE_DEPENDENCIES_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

 

这么小的版本差异也出错,也太挑剔了吧....

就是感觉GTK+ 安装太麻烦了,本来./configure make make install 三步曲就够了,还来这么多限制。。。折腾

还有我想问下,后面那个提示设置" BASE_DEPENDENCIES_CFLAGS"和"BASE_DEPENDENCIES_LIBS "这2个环境变量是怎么回事?要怎么设置才可以

加载中
0
deleted
deleted

差那么多, 不能算很小了....

我建议你直接yum装吧,虽然版本旧点.......你自己编译如果不搞成(个人)全局的,每次运行都要export一堆LD_LIBRARY_PATH, 如果搞成(个人)全局的..说不好哪个系统包调用了你编译的so,然后出故事或者出事故.....

0
jingweiyoung
jingweiyoung

多谢,现在出现个问题,我将“GLib, Pango, Gdk-Pixbuf, ATK"这4个重装,

版本分别是:glib-2.2.1.tar.gz   glib-2.3.0.tar.bz2

glib-2.0.0.tar.bz2,  pango-1.3.2.tar.gz,  gdk-pixbuf-2.24.0.tar.bz2, atk-2.2.0.tar.bz2

奇怪的是glib我试了3个版本,在装gdk, ./configure的时候,总是提示

Requested 'glib-2.0 >= 2.27.2' but version of GLib is 2.3.0

Requested 'glib-2.0 >= 2.27.2' but version of GLib is 2.2.1

Requested 'glib-2.0 >= 2.27.2' but version of GLib is 2.0.0

系统的环境变量:

PKG_CONFIG_PATH="/usr/lib/pkgconfig:/usr/local/lib/pkgconfig:/usr/share/pkgconfig"

实在搞不懂Requested 'glib-2.0 >= 2.27.2'这句话是什么意思???

.....装着个程序花了大半天时间还没装好...纠结在这里了

0
涛儿
涛儿

都提示要大于2.27.2了啊。。。。2.3.0。。。2.2.1。。。2.0.0版本都比27小好不?

而且,这些版本相差真的很大。。。

如果要装gtk3.2.2,建议换Fedora 16以上的系统,别想着自己编译。。。问题很多的。

如果要自己编译,那么下载glib2.30.2,atk2.1.5, pango 1.29.5    cairo 1.10.2  gdk-pixbuf-2.0 2.25 gdk3.2.2

0
jingweiyoung
jingweiyoung
确实...安装glib高版本,又报其他依赖版本不够...哎...程序之间依赖性能不能再大点
0
e
errorcode

楼主折腾好了么?

准备用python,我想升级到3.12

结果看到这个,我觉得蛋疼。。

返回顶部
顶部