Hadoop2.2升级更高版本!!

q443048756 发布于 2016/06/02 13:51
阅读 226
收藏 0

@灵宝 你好,想跟你请教个问题:

        公司用的是Hadoop2.2但现在好多东西跟2.2不兼容所以想升级,首先向知道怎样升级,另外考虑稳定性是升级到2.4就好还是无所谓?因为我并没有看到说哪个高版本的Hadoop有问题!!麻烦您了!

加载中
0
尚浩宇
尚浩宇

2.x会有很多兼容性的问题,1.x和2.x是并行的版本,要是兼容性问题不容忽略还是退到1.x吧


0
灵宝
灵宝
hadoop的版本升级非常快了,你想升级,最好在同一个版本号中升级。比如你们用2.2.X,最好也是在2.2.X中升级,这样可以保证数据没有任何影响。不过考虑到新版本的功能丰富性,和其他hadoop生态组件的支持力,最好升级到2.6.X或2.7.X,这些版本都经过hbase、hive、其他工具的集成测试,方便引入其他功能,具体版本可参考cdh或hdp的hadoop集成版本号。
返回顶部
顶部