在vs2010中使用QT

蒋信 发布于 2012/04/14 20:07
阅读 8K+
收藏 2
Qt

在安装了qt-win-opensource-4.8.1-vs2008.exe和qt-vs-addin-1.1.10.exe后,为什么在vs2010中却不能使用qt。然后,我搜索了关于在vs2010中添加qt库的方法,说是采用静态编译将qt类添加到vs2010中。我是这样做的:

  1. 安装qt-win-opensource-4.8.1-vs2008.exe
  2. 安装qt-vs-addin-1.1.10.exe
  3. 从visual studio command prompt进入安装qt的根目录
  4. 执行configure -platform win32-msvc2010

然后出现下列错误:

perl not found in environment - cannot run syncqt

所以,我想请问一下哪位高手能不告诉我,

  1. 为什么安装了qt-win-opensource-4.8.1-vs2008.exe和qt-vs-addin-1.1.10.exe,在vs2010不能使用qt,而在vs2008中可以使用呢?
  2. 怎么解决上述的错误,或者有没有其它的方法使得能在vs2010中使用qt呢?

 

 

加载中
0
Ruchee
Ruchee

configure的执行需要Perl解释器,你可以安装一个ActivePerl重试

更好的做法是使用QtCreator或换回VS2008

0
szmneo
szmneo

安装vs2010,安装qt,安装addin

什么都没配置,新建qt项目,编译运行成功~


0
不流泪的机场
不流泪的机场
Qt 4.8已经可以支持到VS2010编译了
蒋信
好,我一个支持vs2010的qt
0
kimmking
kimmking

为什么我安装不了qt-vs-addin-1.1.11-opensource

提示找不到vs200x,我用的vs2010beta~~~ 

囧,不支持beta版本么?

0
kimmking
kimmking

引用来自“不流泪的机场”的答案

Qt 4.8已经可以支持到VS2010编译了

为什么我安装不了qt-vs-addin-1.1.11-opensource

提示找不到vs200x,我用的vs2010beta~~~ 

囧,不支持beta版本么?

0
庞仕敏
没遇到这种情况,我在vs下可以用qt4.8和qt3.3.2,只要设置不同的环境变量就可以
0
木头r
木头r
为什么不直接下载vs2010版的qt呢? qt-win-opensource-4.8.1-vs2008.exe是2008版本的``
返回顶部
顶部