ubuntu安装GeoIP问题

yumemor 发布于 2016/01/25 17:47
阅读 942
收藏 0

基本查遍了bbs,google方案都没有用,

这个问题还得追溯到系统上面,32构架和64害人不浅(菜鸟一枚)

使用的是GeoIP1.4.8

直接运行以下程序,说程序是32位构架,不能运行。

这个问题已经困扰我很久了,来大神解答,感谢~ 真的不想换系统,太累。


加载中
0
changnet
changnet
 明明说者libGeoIP.so.1找不到啊。你应该是64位的系统,想跑32bit的程序,就要安装该程序所需要的32bit库。这里明显找不到GeoIP的32bit库。如果你确认你安装了,查一下ldconfig
y
yumemor
已经转centos,谢谢~
0
0-1
0-1

编译GeoIP library

gunzip GeoIP.tar.gz && tar -xvf GeoIP.tar && cd GeoIP-1.4.8 ./configure && make && make install

y
yumemor
已经编译安装过了
0
Feng_Yu
Feng_Yu

sudo apt-get install geoip-bin geoip-database

明明放着软件仓库这个宝库不用,非要玩什么编译?

返回顶部
顶部