hibernate jpa

随性_ 发布于 2015/12/30 18:01
阅读 206
收藏 0

@红薯 你好,想跟你请教个问题:

    红薯大哥,您好;jpa是orm的规范,

我之前hibernate版本是5.0.6,它既是jpa2.1的实现;

<dependency>
   <groupId>org.hibernate.javax.persistence</groupId>
   <artifactId>hibernate-jpa-2.1-api</artifactId>
   <version>1.0.0.Final</version>
</dependency>

但是一直报错:

看源代码,hibernate-jpa-2.1-api中PersistenceUnitInfo接口中含有:

  public abstract ValidationMode getValidationMode();方法;

问题一直没有解决;这个是想请教你的问题?

我后来退而求其次,将hibernate的版本降为4.2.21.final;它既是jpa2.0的实现;

引入该jpa的规范:
<dependency>
  <groupId>javax.persistence</groupId>
  <artifactId>com.springsource.javax.persistence</artifactId>
  <version>2.0.0</version>
</dependency>



程序才能跑通;


跟踪源代码的感觉:好像hibernate-jpa-2.1-api.jar中的接口在项目启动过程中没有被引用到;所以调取不到getValidationMode方法;



加载中
0
红薯
红薯

很多年没玩 Hibernate 了,这个问题我还真回答不了

返回顶部
顶部