如何让2个库使用不同版本的jquery?

unclegaga 发布于 2013/02/28 01:15
阅读 2K+
收藏 5
目前项目用到bootstrap和FusionCharts,但是FusionCharts需要1.4的jquery, bootstrap需要1.8的jquery.尝试引用其中一个版本都会出现问题.如何让2个库各自使用正确的jquery版本?
加载中
1
狂飙的小蜗牛
狂飙的小蜗牛
<!-- 加载jQuery1.8.2版本-->
<script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1.8.2/jquery.min.js"></script>
<script type="text/javascript">
var jQuery_182 = $.noConflict();
</script>


<!-- 加载jQuery1.4.2版本-->
<script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1.4.2/jquery.min.js"></script>
<script type="text/javascript">
var jQuery_142 = $.noConflict(true);
</script>

// 修改FusionCharts 中的$或jQuery为jQuery_142
0
unclegaga
unclegaga

引用来自“ihotte”的答案

<!-- 加载jQuery1.8.2版本-->
<script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1.8.2/jquery.min.js"></script>
<script type="text/javascript">
var jQuery_182 = $.noConflict();
</script>


<!-- 加载jQuery1.4.2版本-->
<script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1.4.2/jquery.min.js"></script>
<script type="text/javascript">
var jQuery_142 = $.noConflict(true);
</script>

// 修改FusionCharts 中的$或jQuery为jQuery_142
试了,可以用.谢谢啦
0
李燕京
李燕京
这个是通一个页面么?
unclegaga
unclegaga
是的 在同一个页面
返回顶部
顶部