jdk1.8下安装jdk1.7后,报Unsupported major.minor version 52.0或Can't load IA 32-bit .dll on a AMD 64-bit platform]错误

zerov 发布于 2016/11/23 18:08
阅读 708
收藏 0

  之前运行没问题,包括tomcat/jetty/maven都正常,jdk为1.8,后为了运行eova,必须用1.7版本,于是又同时安装了jdk1.7,在tomcat和jetty下都报错。jdk、win7、idea15均为64位,错误如下 :

1、tomcat 运行错误:

。。。。Full details will be found in the appropriate container log file。。。

。。。。 [com.alibaba.druid.proxy.DruidDriver] but failed to unregister it when the web application was stopped. To prevent a memory leak, the JDBC Driver has been forcibly unregistered。。。

log中关键一句:java.lang.UnsatisfiedLinkError:\maven-3.3.9\bin\tcnative-1.dll: Can't load IA 32-bit .dll on a AMD 64-bit platform

貌似说maven不是64位的,可系统中明明是64位呀,之前也一直正常。


2、jetty错误:

Artifact eova:war exploded: Server is not connected. Deploy is not available.
Detected server http port: 8080
Exception in thread "main" java.lang.UnsupportedClassVersionError: org/eclipse/jetty/start/Main : Unsupported major.minor version 52.0 

at java.lang.ClassLoader.defineClass1(Native Method)
按major.minor 52.0错误,属jdk高低版本冲突造成的,但我在idea里,已经全部设置为低版本1.7的了

加载中
0
i十十
i十十
.class是用先前的1.8编译出为的。现在用1.7的运行,当然不行。把.class删除,重新编译。
小雪纷飞
小雪纷飞
dasda
zerov
zerov
将target删除后,重新编译,问题照旧
zerov
zerov
谢谢,明天我试试
返回顶部
顶部