unable to get dependency information unable to read the metadata file for artifact

稻草鸟人 发布于 2012/12/04 17:48
阅读 3K+
收藏 0

对于maven我相信大家和我一样用了之后就不会再想回到导jar的那个年代了,但是最近小弟我遇到一个问题,就是在pom.xml文件中添加如下依赖的时候发生了如题的错误信息


        <dependency>
            <groupId>org.apache.axis2</groupId>
            <artifactId>axis2-transport-http</artifactId>
            <version>1.5.1</version>
        </dependency>

我用到的中央仓库和远程仓库:http://maven.apache.org

                                            http://repo1.maven.org/maven2/

                                            http://developer2.ncibi.org/maven/

有没有哪个兄弟有添加过axis2 1.5.1的依赖遇到过这样的问题?是如何解决的呢?求教

PS:我用的开发工具是IDEA,里面有个检查机制  Inspects a Maven model for resolution problems

   就是它在捣乱,不知道这个Inspeciton是否有必要?       

加载中
0
0xTang
0xTang
我现在也遇到这个问题了。。。。也是用IDEA。。。。
0
0xTang
0xTang

我这边找到原因了,报的错误是我们自己的一个开发的jar。。unable to get metadata fie for artifact ***.jar(***是我们自己的jar)

原因是我们同事用到的parent的version是snapshot的,IDEA不支持读取snapshot的jar,他改成stable版本之后再上传到仓库,我再拉下来之后reimport就解决错误了。。。。

返回顶部
顶部