导入公司的maven项目到eclipse,结果出了一个很棘手的问题,请大家帮我看看~

尾小戒1993 发布于 2016/01/26 16:15
阅读 731
收藏 0

用git下载下来公司的maven项目源码,然后导入到eclipse中,maven已经把依赖包下载下来了,结果一发布就出了下面的奇葩问题:

上面的异常大致就是说org/objectweb/asm/Type这个类找不到,但是我看了pom.xml,里面根本没写有关这个类的jar包,所以公司项目按理说是不需要这个包的(如果需要pom里面应该写上配置才对)

我又继续往下看,发现有这么些错误:

所以现在开始怀疑是不是maven的错?

首先确定一点的是:公司源码是在jdk1.6写的,而我本地jdk是1.7版本的,但是这应该没什么影响吧?不是说从上向下兼容吗?

所以就迷惑了,公司源码是直接下载的,环境也都搭建好了,jar包也都靠maven下载下来了,怎么还会出这种错误呢。。

加载中
0
一书生
一书生

请参考:

http://appleses.iteye.com/blog/1753854

0
panmingguang
panmingguang
pom 没写 不代表 不需要, 依赖的包, maven会自动下载所有依赖的, 没有这个包 就到本地目录找一下, 重新下载
返回顶部
顶部