安装PHP5.3 NTS 的方法

bowen1966 发布于 2015/11/03 11:13
阅读 803
收藏 0
PHP

@金三胖 你好,想跟你请教个问题:

我用你网上说的安装PHP5.3 NTS 的方法仍不能正确安装,我用WIN7,请指教。我QQ:583612817

加载中
1
金三胖
金三胖
抱歉,我也不懂-_-#我平时在Mac上写PHP,直接brew安装的。Win上也有PHP环境,不过是集成环境。
0
mickelfeng
mickelfeng

如果是使用ISAPI的方式来运行PHP就必须用Thread Safe(线程安全)的版本;
而用FastCGI模式运行PHP的话就没有必要用线程安全检查了,用None Thread Safe(NTS,非线程安全)的版本能够更好的提高效率。

vc运行库安装了吗,win7上一般跑vc8、9了把,php5.3下载源,你看有没有哪个vc运行下编译的版本适合win7

0
金三胖
金三胖
开发学习,建议集成环境就行,方便快捷
0
b
bowen1966
我是因为要用zend guard 6.0才安装PHP5.3 NTS的,因为网上说zend guard 6.0只能支持PHP5.3 NTS。可折腾3天了,也装不上PHP5.3 NTS
b
bowen1966
回复 @金三胖 : guard 6.0加密过的PHP文件只有在PHP5.3 NTS的环境下才能被识别, 我安装PHP5.3 NTS环境是为了运行guard 6.0加密过的PHP文件。
金三胖
金三胖
用Zend Guard 需要先安装PHP?我记得以前用的时候没这说法啊。6.0是支持PHP5.3的代码加密,不是需要PHP5.3的环境吧。你是不是看错了。
0
南湖船老大
南湖船老大

什么叫安装不上。。。你总得给个说法啊,安装不上是什么意思?报什么错了?启动不来?八婆错日志是啥?

你不能这么提问啊。。。

0
b
bowen1966
网上说zend guard 6.0加密过的PHP文件只有在PHP5.3 NTS的环境下才能被识别,所以,没有PHP5.3 NTS的环境,zend guard 6.0加密过的PHP文件不能用
返回顶部
顶部