eaccelerator安装后无法识别

ain017 发布于 2012/03/15 12:32
阅读 977
收藏 0

【华为云1024程序员节·向云而生】预约直播 抽14件华为电子产品礼包!>>>

前几天在网上发了帖子,eaccelerator还是装不上去啊,在网上搜了好多指导文章,大概的步骤就是:

1、解压后,进入eaccelerator文件夹,然后运行/usr/local/php/bin/phpize,然后出现:

PHP Api Version:         20090626
Zend Module Api No:      20090626
Zend Extension Api No:   220090626

2、然后就安装:

./configure --enable-eaccelerator=shared --with-php-config=/usr/local/php/bin/php-config

3、make && make install之后得到eacclerator.so文件的位置:

[root@ localhost eaccelerator-0.9.6.1]# make install
Installing shared extensions:     /usr/local/php/lib/php/extensions/no-debug-non-zts-20090626/

4、建立缓存目录后,然后把这个地址放在php.ini中:

打开php.ini文件,在下面输入

extension_dir = "/usr/local/php/lib/php/extensions/no-debug-non-zts-20090626/eaccelerator.so"
extension = "eaccelerator.so"

eaccelerator.shm_size="128"
eaccelerator.cache_dir="/tmp/eaccelerator"
eaccelerator.log_file = "/var/log/httpd/eaccelerator_log"
eaccelerator.enable="1"
eaccelerator.optimizer="1"
eaccelerator.check_mtime="1"
eaccelerator.debug="0"
eaccelerator.filter=""
eaccelerator.shm_max="0"
eaccelerator.shm_ttl="0"
eaccelerator.shm_prune_period="0"
eaccelerator.shm_only="0"
eaccelerator.compress="1"
eaccelerator.compress_level="9"

今天换了apache2.4服务器试试,前几天用的是nginx + php-fpm。我想apache可能会好调一些,但是这样还是不能识别eaccelerator:

加载中
0
kerriganA
kerriganA
打一下 /usr/local/php/bin/php -v看。是啥出错的信息一般
0
a
ain017
解决了 版本问题
0
郭凯
郭凯

引用来自“ain017”的答案

解决了 版本问题

你用apache2.4+php5.3.10配置好了?

apache2.4是用什么方式来运行PHP的?是fastcgi嘛?PHP是通过什么方式来运行的?是php-fpm嘛?

如果是的话,求配置呀

0
月影又无痕
月影又无痕

EA是第三方的代码,推荐使用APC,不要使用EA了。

我在生产环境中使用过EA, 但是发现其会导致php负载极不稳定(也可能是我配置的问题,没有深入研究),禁止EA就正常,换成APC之后,一直没有出现不稳定因素。

于是后来,一律安装APC,不再使用EA

返回顶部
顶部