有没有能兼容各浏览器的前端开发框架?easyui好像不支持ie了

rihgtzhao 发布于 2014/06/19 17:01
阅读 6K+
收藏 0

用过dwz,但是不更新了。

想用easyui,但是好像不支持ie。

哪位老师介绍个兼容度好,文档又全,又好用的前端框架哈,呵,是不是要求太高了。

加载中
0
xmut
xmut

想完全兼容各种浏览器,尤其是各个版本的前端开发框架,目前几乎没有,或者本人还不知道

文档全的开发框架多的是,比如你用的EasyUI,还有ExtJS……数不尽!

好不好用是看你的需求。简单的增删查改还用ExtJS,那当然不好用,至少没HTML+CSS好用!

开发类似C/S效果的信息系统(比如进销存)或者单页模式的话,用ExtJS,那当然是好用!


0
g
gpwsfa
用bootstrap3,立志兼容各种浏览器,由twitter团队开发,最新Visualstudio也引入了此框架,并且具有响应式布局模式,兼容各种分辨率的屏幕
0
xmut
xmut

引用来自“gpwsfa”的评论

用bootstrap3,立志兼容各种浏览器,由twitter团队开发,最新Visualstudio也引入了此框架,并且具有响应式布局模式,兼容各种分辨率的屏幕
对你很无语!什么叫“ 立志兼容各种浏览器”? Bootstrap团队从一开始就不准备兼容IE8以下的浏览器!!!即便自己不知道,也不能误人子弟!
0
javadeveloper
javadeveloper
还是用用ligerui吧,基本上我看到的IE6还是兼容的,其他浏览器兼不兼容你明白的。
0
阿水plus
阿水plus
果断抛弃对IE6,7的兼容,你的眼前就一片开阔了
0
g
gpwsfa

引用来自“xmut”的评论

引用来自“gpwsfa”的评论

用bootstrap3,立志兼容各种浏览器,由twitter团队开发,最新Visualstudio也引入了此框架,并且具有响应式布局模式,兼容各种分辨率的屏幕
对你很无语!什么叫“ 立志兼容各种浏览器”? Bootstrap团队从一开始就不准备兼容IE8以下的浏览器!!!即便自己不知道,也不能误人子弟!
我道歉,能兼容IE4和5的我还没有找到
0
兜风儿
http://www.h-ui.net/index.shtml
0
唐代de豆腐
唐代de豆腐

建议用EXTJS,,最好是用3.4稳定版本,,当然你也可用4.2版本。。但是3.4与4区别蛮大。

我建议你学习3.4就好。例子会更多,有助于你学习。 

0
最好的UI框架QUI
最好的UI框架QUI
看了这个很有体会,我个人开发前端UI框架也用了5年时间,5年前市场上基本上


没有前端框架的产品,5年耗费了不少心血,我仔细把国外国内各种产品都对比


的很详细 ,优劣势分析的很细致,个人觉得我的QUI框架算是性价比算比较高的


了,懂的朋友可以交流下,给点意见,共同成长。 这是我自己的网站, 


www.quickui.net
返回顶部
顶部