jdk1.7到1.8,环境变量需要修改吗

fgod 发布于 2016/10/25 14:58
阅读 2K+
收藏 0

http://note.youdao.com/noteshare?id=9cc38aa23cb269054c25462f83ca4044

windows今天安装了jdk8,java -version直接就是jdk1.8.

这对于我们开发不会有影响的吧。。

还需要我们去切换环境变量吗?

加载中
2
阿信sxq
阿信sxq

说一下,安装jdk的时候安装到jre的时候就不要安装了,直接退出,那样就不会自动添加环境变量引起你这个误会了。

安装完成之后一定要确认java -version和javac -version都是1.8的才可以,你目前的,javac -version应该还是1.7的,那样不行

1
黑狗
黑狗

需要改变 你要多设置几个环境变量

黑狗
黑狗
回复 @554330833a : 开发环境要jdk 服务器上你用jre就是了
554330833a
554330833a
可以只有一个jdk,换多个jre的吗?
黑狗
黑狗
JDK7_HOME JDK8_HOME JAVA_HOME PATH 你需要把JAVA_HOME指向到你希望用的jdk目录去(此jdk版本和生产环境要一致)
0
求是科技
求是科技
很明显不需要撒,环境变量的作用是啥,紧紧只是为了方便的找到
JPer
JPer
也不一定哈,如果目录带着版本号不修改肯定找不到啊
0
银杏果果
银杏果果
jdk默认安装的安装目录是带版本号的,如果安装目录不同是应该修改环境变量的
0
zparkdong
zparkdong
java -version都是1.8,应该就不用改环境变量了
0
亡鱼
java -version 个人理解只是jar的版本吧,你javac -version看看是不是1.7?还是需要改的吧?
0
蓝水晶飞机
蓝水晶飞机
1.8版本完全没有问题,你喜欢用着1.6,1.7的语法可以继续用。
返回顶部
顶部