在OpenSOC环境部署过程中,向storm提交拓扑时,报zookeeper错误信息,求助

Kkidou 发布于 2016/03/09 23:55
阅读 1K+
收藏 0

运行 OpenSOC的示例程序 ,向storm中提交拓扑

出现如下错误log日志信息,程序不能正常运行

29246 [Thread-24-KafkaSpout] ERROR backtype.storm.util - Async loop died!
java.lang.NoSuchMethodError: org.apache.zookeeper.ZooKeeper.<init>(Ljava/lang/String;ILorg/apache/zookeeper/Watcher;Z)V

at org.apache.curator.utils.DefaultZookeeperFactory.newZooKeeper(DefaultZookeeperFactory.java:29) ~[OpenSOC-Topologies-0.6BETA.jar:na]
        at org.apache.curator.framework.imps.CuratorFrameworkImpl$2.newZooKeeper(CuratorFrameworkImpl.java:169) ~[OpenSOC-Topologies-0.6BETA.jar:na]
        at org.apache.curator.HandleHolder$1.getZooKeeper(HandleHolder.java:94) ~[OpenSOC-Topologies-0.6BETA.jar:na]
        at org.apache.curator.HandleHolder.getZooKeeper(HandleHolder.java:55) ~[OpenSOC-Topologies-0.6BETA.jar:na]
        at org.apache.curator.ConnectionState.reset(ConnectionState.java:219) ~[OpenSOC-Topologies-0.6BETA.jar:na]
        at org.apache.curator.ConnectionState.start(ConnectionState.java:103) ~[OpenSOC-Topologies-0.6BETA.jar:na]
        at org.apache.curator.CuratorZookeeperClient.start(CuratorZookeeperClient.java:188) ~[OpenSOC-Topologies-0.6BETA.jar:na]
        at org.apache.curator.framework.imps.CuratorFrameworkImpl.start(CuratorFrameworkImpl.java:234) ~[OpenSOC-Topologies-0.6BETA.jar:na]
        at storm.kafka.ZkState.<init>(ZkState.java:62) ~[OpenSOC-Topologies-0.6BETA.jar:na]
        at storm.kafka.KafkaSpout.open(KafkaSpout.java:85) ~[OpenSOC-Topologies-0.6BETA.jar:na]
        at backtype.storm.daemon.executor$eval5100$fn__5101$fn__5116.invoke(executor.clj:519) ~[na:na]
        at backtype.storm.util$async_loop$fn__390.invoke(util.clj:431) ~[na:na]
        at clojure.lang.AFn.run(AFn.java:24) [clojure-1.4.0.jar:na]
        at java.lang.Thread.run(Thread.java:745) [na:1.7.0_79]

参考其他网络帮助,说是 zookeeper版本不正确, 但是好像我第一次提交拓扑的时候就没有出现这种问题,

程序运行正常,之后再次提交的时候,环境也没有变化,就是重启了下集群环境,确认storm  kafka zookeeper工作正常,而且也确认了pom.xml中的依赖中没有zk的版本消息,想各位请教下

加载中
0
qeeainburg
qeeainburg
同样的问题,解决了吗?
0
Kkidou
Kkidou
很抱歉现在才看到,我之前报这种错误考虑是版本的问题,最后重新换了 Zookeeper3.3.6的版本才解决的,貌似
OSCHINA
登录后可查看更多优质内容
返回顶部
顶部