Ubuntu系统VPS下Nginx配置多域名失败,是否是配置的原因?

candura 发布于 2015/07/04 15:57
阅读 456
收藏 0

系统环境Ubuntu 14.04 x86。

我之前是完全按照VPS-Ubuntu中文这篇文章的方法来从头配置Nginx主机,可是当我在"/etc/nginx/sites-enabled/"目录下放入另外一个域名的信息的时候,都无法配置成功,使用“service nginx restart”重启Nginx服务的时候也都是失败(Fail)……

VPS上“/etc/nginx/sites-enabled/”目录下有“default”和“*.xxx.com”两个配置文件,代码分别如下:

default:

server {
   listen 80 default_server;
   listen [::]:80 default_server ipv6only=on;

   root /var/www;
   index index.html index.htm index.php;

   server_name *.*.*.*(主机所在IP地址);

   location / {
      # First attempt to serve request as file, then
      # as directory, then fall back to displaying a 404.
      try_files $uri $uri/ =404;
      # Uncomment to enable naxsi on this location
      # include /etc/nginx/naxsi.rules
        if (!-e $request_filename)
        {
                rewrite ^/(.+)$ /index.php last;
        }
   }
   
   location ~ \.php$ {
      include /etc/nginx/fastcgi_params;
      fastcgi_param  SCRIPT_FILENAME    $document_root$fastcgi_script_name;
      fastcgi_pass  127.0.0.1:9000;
      }
}


另外一个配置文件如下
server   {
   listen       80;
   server_name *.xxx.com;
   index index.html index.htm index.php;
   root  /var/www/*/;
   location ~ \.php$ {
      include /etc/nginx/fastcgi_params;
      fastcgi_param  SCRIPT_FILENAME    $document_root$fastcgi_script_name;
      fastcgi_pass  127.0.0.1:9000;
      }
   }

是不是我这样配置有冲突造成配置失败的呢?请教一下应该如何正确配置?

以下是问题补充:

@candura:重启Nginx服务的时候系统就说了个“Fail”,后面我看error.log的时候,发现了这一条“2015/07/03 22:37:16 [emerg] 5169#0: unknown directive "?server" in /etc/nginx/sites-enabled/*.xxx.com:1” (2015/07/05 12:30)
加载中
0
冬芽
冬芽

具体错误是什么?

c
candura
回复 @Slayer : 好吧,后面从头开始全部配置用VIM在VPS上进行编写,然后终于成功并生效了……感谢解答~
c
candura
回复 @Slayer : 后面我在VIM下面重新修改并保存之后没有问题了,可以正常重启Nginx服务,但是配置文件还是没有生效。
冬芽
冬芽
回复 @candura : 删掉重新建一个文件试试
c
candura
回复 @Slayer : 可是我用VIM来打开看前面也是没东西的。。。
冬芽
冬芽
回复 @candura : server 前面那个问号去掉看看,应该是不小心打了个特殊的字符乱码了
下一页
返回顶部
顶部