9
回答
maven中的pom.xml已经加入commons-configuration的依赖配置,为何myeclipse项目没有依赖上?
【腾讯云】学生服务器套餐10元/月 >>>   

是这样的.

从svn上down下来了一个分模块的maven项目,其中service模块中用到了commons-configuration的依赖。

好,我在pom.xml中加入:

<dependency>
<groupId>commons-configuration</groupId>
<artifactId>commons-configuration</artifactId>
<version>1.6</version>
</dependency>
但是在项目中的发现不了它的jar包,用不了commons-configuration相关的api。谁有碰到过的码?草,纠结啊。

举报
bobJiao
发帖于3年前 9回/1K+阅
共有9个答案 最后回答: 3年前
可能是网络的问题,看看仓库里面commons-configuration包是否已经下载下来,实在不行自己找个jar 用mvn install安装到本地仓库

mvn eclipse:clean

mvn eclipse:eclipse

你试试

--- 共有 1 条评论 ---
Ambitor先去你maven本地库看下 jar包下下来没。。如果是.lastupdate结尾 文件 删掉重搞 3年前 回复

引用来自“小小志”的评论

可能是网络的问题,看看仓库里面commons-configuration包是否已经下载下来,实在不行自己找个jar 用mvn install安装到本地仓库

这个路径对吗?这应该是我运行maven的相关命令自己下载的.

引用来自“小小志”的评论

可能是网络的问题,看看仓库里面commons-configuration包是否已经下载下来,实在不行自己找个jar 用mvn install安装到本地仓库
下载了,不知道路径对不对?,我把图贴到下面的回答了.

引用来自“Ambitor”的评论

mvn eclipse:clean

mvn eclipse:eclipse

你试试

按你说的做了,很神奇的结果:

[INFO] xxx ............................................ SUCCESS [  1.437 s]
[INFO] xxx-parent ..................................... SUCCESS [  0.032 s]
[INFO] xxx-webparent .................................. SUCCESS [  0.052 s]
[INFO] xxx-common ..................................... SUCCESS [  1.682 s]
[INFO] xxx-dao ........................................ SUCCESS [  0.542 s]
[INFO] xxx-service .................................... SUCCESS [  0.243 s]
[INFO] xxx-api ........................................ SUCCESS [  0.208 s]
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESS
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 5.106 s
[INFO] Finished at: 2015-10-28T20:41:31+08:00
[INFO] Final Memory: 21M/335M
[INFO] ------------------------------------------------------------------------

评论(0)引用此答案修改删除举报 (2015-10-28 20:42)

引用来自“Ambitor”的评论

mvn eclipse:clean

mvn eclipse:eclipse

你试试

那个错误仍然在,它是在sevice中的错误,会影响我打web的包.
--- 共有 3 条评论 ---
Ambitor回复 @bobJiao : 有时间你多贴几张图 把信息弄出来哦,呵呵 我想到的都告诉你怎么处理了。你在琢磨琢磨 3年前 回复
bobJiao回复 @Ambitor : 我的classpath是这样的,其中有一条依赖是对Maven Dependencies这个Library的依赖: <classpathentry kind="con"path="org.maven.ide.eclipse.MAVEN2_CLASSPATH_CONTAINER"/> 3年前 回复
Ambitor啥错误,按道理按上面的执行 SUCCESS后 就可以正常大包了哦。。你可以多去了解mvn的命令,在这之前 你可以先检查下 你本地maven库是否已经down下了完整的jar包。然后再查看你项目的.classpath文件是否已经引用jar包,如果有。clean下工程 应该就可以了哦。。正常的是这样的。 3年前 回复
顶部