windows7下snort安装配置中的问题

hetwen 发布于 2012/02/16 17:46
阅读 3K+
收藏 0
在安装acid时出现的错误, trict Standards: Declaration of MultipleElementCriteria::SanitizeElement() should be compatible with that of BaseCriteria::SanitizeElement() in D:\webserver\htdocs\acid\acid_state_citems.inc on line 283

Strict Standards: Declaration of MultipleElementCriteria::PrintForm() should be compatible with that of BaseCriteria::PrintForm() in D:\webserver\htdocs\acid\acid_state_citems.inc on line 283

Strict Standards: Declaration of MultipleElementCriteria::AddFormItem() should be compatible with that of BaseCriteria::AddFormItem() in D:\webserver\htdocs\acid\acid_state_citems.inc on line 283
等等
打开acid_main.php时也出现类似错误,另外,有提示:
Analysis Console for Intrusion Databases


Deprecated: Function eregi_replace() is deprecated in D:\webserver\htdocs\acid\acid_db.inc on line 196

Deprecated: Function eregi_replace() is deprecated in D:\webserver\htdocs\acid\acid_db.inc on line 197
The underlying database snortdb@localhost appears to be incomplete/invalid.

The database version is valid, but the ACID DB structure (table: acid_ag) is not present. Use the Setup page to configure and optimize the DB.

已经整了两天了,还是没解决,求高人指点!!!

加载中
0
h
hellozyj
你好,我也遇到这个问题,你解决了吗?
0
h
hetwen
我觉得是老版php语法不严格,而且adodb里面的SQL语句有错,所以无法建表,需要手动在数据库中建表,还有我在php.ini中关闭了错误显示,display_error=off,如果有需要,发邮件至hetwen88@gmail.com
返回顶部
顶部